Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
MY c32 is running at 11MPG on highway and when its ideal, it shows 5.9 mpg when my car inst even moving. Any idea what needs to be replace or fix?

All my tires are at 34 psi.
 

·
Registered
2000 Mercedes-Benz S500. Sold: 2000 C230K, Sold: 1997 Porsche 944S
Joined
·
1,271 Posts
MY c32 is running at 11MPG on highway and when its ideal, it shows 5.9 mpg when my car inst even moving. Any idea what needs to be replace or fix?

All my tires are at 34 psi.
Assuming your car is mechanically sound you can do some simple checks before assuming its a major repair.

Replace Fuel Filter
Oil Change with new Oil filter with O-Rings
Replace your Air Filter
Clean out AF Housing
Clean your MAF
Introduce 1 Can of Seam Foam AFTER the Fuel Filter change.

Front and Rear tires should not be the same PSI
Mine is factory 28PSI Front, 32PSI Rear
But I bump it up +5PSI for personal preference.

Why your MPG is registering at stand still is beyond me.
The other stuff WILL improve your MPG.
 

·
Registered
2002 C32 AMG
Joined
·
12 Posts
Before you get crazy and start replacing parts do a manual test to see your actual MPG. The next time you go to the pump see how much fuel you put it and then see how much miles it gives you until your next fill up (you will need to record how much fuel you put in the second time as this will give a good approximation of fuel consumed for the miles covered). Do not trust your car instruments for this test; use an alternate means to calculate distance.

Most likely you have a problem with the instruments. If your car was giving you that bad a fuel mileage you would have a trail of black smoke following you everywhere or your car was pushing out unburned fuel. To test for unburned fuel put your hand behind the tailpipe for about 10 secs. If it smells like gasoline you have a problem.

Let me know how it goes.

DM
 

·
Registered
2000 MB
Joined
·
803 Posts
Hello ,
Just visiting from the w210 forum. Maybe a change on your maf? How old is your car anyway ? Thanks .
 

·
Registered
2002 C32 AMG
Joined
·
12 Posts
I seriously doubt that it is the MAF. If it was the check engine light would be illuminated as the car would run either too rich or too lean causing the car to smoke or have a milk white tail pipe. also the performance would be compromised giving a very poor throttle response time (if it was not functioning as car would be using computer values). One way to test the MAF is to unplug it and see if the car runs the same.

DM
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Thanks for the respond, i don't smell any thing from the tail pipe. from what you wrote, i think is my MAF. when i hit the throttle, it does not respond after a 1 and 1/2 seconds later.

By chances you know where is the MAF in our C32? some people say that we only have a MAP but not MAF in the c32. what is the part number and where is it located? how much is that MAF/MAP part?

thanks in advance
 
1 - 8 of 8 Posts
Top