Mercedes-Benz Forum banner

1 - 20 of 22 Posts

·
Registered
2004 Acura TL, 1999 GMC Yukon
Joined
·
1,658 Posts
Discussion Starter #1
My car now wants to idle at 500rpm. When it stays at 500 it dies, as it did yesterday at an intersection. I took the airbox off to adjust the idle, and I was at a standstill in about 5 min. Any ideas why my idle is so low now?
 

·
Registered
2004 Acura TL, 1999 GMC Yukon
Joined
·
1,658 Posts
Discussion Starter #4
I'll need to look up where the ICV and idle air valve are. Dang my ignorance!
 

·
Registered
1983 300 SD, 1991 420 SEL, 1979 300SD
Joined
·
536 Posts
hmmmm, did someone hijack Dimmuburger's account? someone with over 1600 posts should know where the IACV valve is
 

·
Registered
2004 Acura TL, 1999 GMC Yukon
Joined
·
1,658 Posts
Discussion Starter #6
Nice! I apologize for only changing my oil in the past year. I'll search posts for answers, I suppose.
 

·
Registered
1985 380se
Joined
·
34 Posts
My '85 380se has idled at 500 rpm since I got it... and has never had a stalling problem at the low rpm's... it may be something else such as ignition control valve... my car would just die while driving (around 1200 - 1500 rpm) and my mechanic pinpointed it as ICV.
 

·
Registered
1983 300 SD, 1991 420 SEL, 1979 300SD
Joined
·
536 Posts
I wasn't trying to be rude or anything; sorry if it came across like that. i just thought someone with that many posts is a Mercedes Expert :); and it is possible for someone to steal you account btw.
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
et7724
If you had read this forum a year or so ago you would know that Sam aka Dimmuberger had a terrible accident and we are extremely happy that he is recovering.

Sam,
The Idle Control Valve is the round item to the left of the distributor has a two pin plug on it. Air slide valve is on some Euro Cars and it is in approximately the same place but sits in a vertical position, while the ICV lays flat and points towards the Air Metering disc. Connected to the cold start valve and the air plenum under the fuel distributor/air metering assy.
 

·
Registered
1989 560SEC
Joined
·
2,056 Posts
Dimm,

The IVC is the long cylindrical item right in front of the air cleaner (see photo). Try soaking it in parts cleaner to remove any carbon build up. To test it, unplug the unit and the idle should increase to above 1K rpm. If it does not, you have other problems. Disregard the screw that I have in stalled in the attached photo. I was trying to manually control my idle and this worked for a little while.

Mike
 

Attachments

·
Registered
2004 Acura TL, 1999 GMC Yukon
Joined
·
1,658 Posts
Discussion Starter #14
I had my wife start the car while I was under-hood, with the IVC unplugged, and it started right up and idled at about 1100rpm. I re-installed the IVC and the idle didn't change. She left an hour ago to fetch some things from Wal-Mart, and some carb/componant cleaner for me. The IVC is sitting on my tablesaw waiting for a container of cleaner to soak in overnight. I appreciate the help here SO MUCH! THANK YOU!
 

·
SuperModerator
1986/1990 W126
Joined
·
14,132 Posts
I found soaking them for ages works. Takes at least a week, or has for me anyway.
But give it a try n see. If your idle didn't change, I wonder if its just buggered. If it it, thetes plenty of used ones about.
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
I have sprayed mine with electrical contact cleaner, sprayede the bejeebers out of it, until only clean cleaner came out the two ports, and it worked, took a few minutes, not morwe than an hour to get clean cleamer flowing out. I cap off the port in the right and turn it upside down so the electrical connections are on the bottom and spray into the open port and shake the bejeebers out of it, repeat till clean and re install. works for me. Have done Ianrandoms process as well both work.
 

·
Registered
2004 Acura TL, 1999 GMC Yukon
Joined
·
1,658 Posts
Discussion Starter #17
Well my Polly returned with a gallon container of parts cleaner (Berrymans). The paint-can container has a plastic tray built in, and I left the IVC in the tray, in the solvent for 7 or 8 hours, and left the IVC port side down on a clean place in the driveway this morning at 3:30. I'll reinstall it this morning at about 8 before I go to see my job-therapist this morning at 9. Maybe I should've let my wife buy the spray instead. We'll see!
 

·
Registered
2004 Acura TL, 1999 GMC Yukon
Joined
·
1,658 Posts
Discussion Starter #18
Well, it started right up and idled at 700rpm. I drove it a few miles in town this morning and it never acted strange, and the idle stayed at 700. Perfect again on the way home. Now I need to fix the headliner and the AC. Great car!
 

·
Registered
1989 560SEC
Joined
·
2,056 Posts
Well, it started right up and idled at 700rpm. I drove it a few miles in town this morning and it never acted strange, and the idle stayed at 700. Perfect again on the way home. Now I need to fix the headliner and the AC. Great car!
Fabulous! I have got to do my headliner soon as well.

Mike
 
1 - 20 of 22 Posts
Top