Mercedes-Benz Forum banner
1 - 13 of 13 Posts

·
Registered
'99 ML430, 06 SRX AWD
Joined
·
328 Posts
Discussion Starter · #1 · (Edited)
Hello,

I have 120k miles and a 500 miles on new PEI transmission.

The car idles about 6-700 in park and 550 - 500 in drive. No cel lights and runs exteremely strong with new trans.

The cold weather came monday and today 30 - 40 F. I start truck in the morning allowing it to drop from high idle and when I put it in drive it almost stalled but I took my foot off the brake.
It did stall once in reverse monday but I didn't allow it to warm up much at all maybe +30 seconds. As I sit at a traffic light 5 minutes from the house you can feel and watch the tach drop to 500 and back as the various pumps etc switch on and off. Makes me nervous but hasn't stalled yet

It is due plug wires and probably a battery but I would think the ECM module would control idle and as I said it runs GREAT, hard accel activates traction control on dry pavement like it did when new.

Once warm, idle is still low, but doesn't seem to hit that 500 mark. I am thinking the Idle Air Control valve, but I haven't seen anyone else posting comlpaints about it.

any other suggestions ?

Thanks
David
 

·
Registered
Dallas, Texas
Joined
·
10,093 Posts
M112 engine does not have separate idle control valve. All functions are performed using electronic throttle actuator. Remove air intake pipe at throttle and inspect for junk buildup. Wipe with rag soaked in carb cleaner. Don't spray anything inside intake manifold. Get new seal for intake pipe.

Try doing throttle adaptation. Turn key on for >60 seconds do not touch accelerator. You will hear whine from throttle area. After 60 seconds turn key off for >10 seconds. Start engine and recheck idle.
 

·
Registered
'99 ML430, 06 SRX AWD
Joined
·
328 Posts
Discussion Starter · #3 ·
Thanks, I have the M113, V8, so I guess I have to remove the coolant resevoir ?

Do you have a pt# for the gasket, but it may be dif. for the V8 I guess ?

Will try this weekend.
 

·
Registered
Dallas, Texas
Joined
·
10,093 Posts
ML430 may have one of the two numbers 112 159 00 80 or 112 159 01 80. They are $4 each. Get both so you don't get caught with your pants down on the weekend.


.
 

Attachments

·
Registered
'99 ML430, 06 SRX AWD
Joined
·
328 Posts
Discussion Starter · #5 ·
Found air intake tube's lower locking clip was broke and missing, it was the 2 groove seal. I think it has been that way since MB built motor for oil useage 80K miles ago, valve cover bolt probably held in place.
Just in case, I bought a new tube and replaced 4yr old Batt. (MB "said" it tested bad a few months ago). Cleaned throttle and relearned idle per your procedure. It still idles a hair over 500 in drive. It is 47f outside and seems to have problem below 40F, I will have to wait until morning.

1) The Idle Air Control valve autohaus sells, for the M113. It sits infront of the secondary injection pump on the pass. side. Do you know if that controls engine idle or is it related to the air pump?

2) While relearning idle, (key on for my than 60sec.) I could hear a buzzing from directly under the intake manifold. I laid my ear on the manifold to confirm. Do you know what makes that noise ?

Thanks
David
 

·
Registered
Dallas, Texas
Joined
·
10,093 Posts
1) Valve next to the pump controls vacuum to air injection valves. Has nothing to do with idle.

2) Sound you hear is electric motor inside throttle actuator doing adaptation.

Do you have scanner that reads live data stream?
 

·
Registered
Dallas, Texas
Joined
·
10,093 Posts
See if you can plot throttle angle and engine speed with just key on, at fast idle right after cold start, cold idle and in Drive.

Last ditch hack may be gluing small shim in throttle value sensor.
 

·
Registered
'99 ML430, 06 SRX AWD
Joined
·
328 Posts
Discussion Starter · #10 ·
I will try to get someone the work pedal while checking clearance.

I am considering the MAF sensor also, since the idle changes with outside air temp. Anyone know the values to check for ?

Is it +1.00 volt with key on, engine off means bad ?
 

·
Registered
ML320 2002
Joined
·
1,668 Posts
Idle irregularity is not a quick fix since you are shooting into the darkness without any error code to start with. It can be very simple or complex solution. I recommend checking everything before replacing starting with the simple things. Since you ruled out the leak from air intake pipe, also look at crankcase ventilation hoses. These can get hard and crack over time. MAF is easy to blame but not the most common reason. I paid for a new MAF, replaced spark plugs and wires to fix the idle irregularity and turns out none of them was the cause.

BTW, if you haven't found a obd scanner yet, this one can read live throttle position or live O2 sensor data and graphs data.

CAN OBD II Code Reader/ EOBD Scanner
 

·
Registered
'99 ML430, 06 SRX AWD
Joined
·
328 Posts
Discussion Starter · #13 ·
Totally agree, just doing the needed maintenance things first.

Wife doesn't think there is a problem but it also has been above 40f when she has driven it. Until it throws a light or stalls, I won't get real aggressive. Air temp. is to drop drastically next week, should be a good test.

I am hoping it just needs to relearn drivablity settings or the torque converter is alittle tight. Probably have 90K on this MAF sensor. I may clean b4 replacing and see if anything changes if it passes the above tests.

What ended up solving your issue ?
 
1 - 13 of 13 Posts
Top