Mercedes-Benz Forum banner

Low beam headlight not working after replacing bulb

494 Views 9 Replies 3 Participants Last post by  HondaCT70NuT
Hello everyone. I’m new here and I’m sure someone has asked this question before but I’m about to pull my hair out trying to figure this out. I replaced the low beam bulb on the right side and it still isn’t working. Checked the fuses and they are good. So here’s my question…. Do they need to be coded in order to work and if so does anyone know if that can be done yourself or do you have to take it to the dealership. Thanks in advance for any help.
1 - 10 of 10 Posts

· Registered
2005 CLK55 AMG Coupe ,CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Joined
·
2,623 Posts
There is no need to code anything.
Be certain that the bulb is the correct type and is good and fitted correctly.
Also check the wires in that area for any damage, sometimes the insulation degrades due to heat.
You could try swapping the bulbs from side to side ,,
if it still doesn't work ,
you will need to test for power and /or have an auto electrician check it out.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
The bulbs are definitely the correct ones and I have swapped them and still nothing. I will check the wires first thing in the morning. Could it be the ballast or how do I go about testing the ballast to see if it’s still good? I really appreciate you taking the time to reply to my question. Thank you so much
 

· Registered
2005 CLK55 AMG Coupe ,CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Joined
·
2,623 Posts
You are very welcome.
Sorry I have only basic electrical knowledge , I don't know much about ballast / testing etc..
Do you have Zenon lights ? Which model CLK ?
 

· Registered
2005 CLK55 AMG Coupe ,CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Joined
·
2,623 Posts
This may help . It could be a bad ballast.
 

· Registered
2006 CLK350 Sport
Joined
·
22 Posts
I have found the sleeving on the wiring in this Era of Mercedes Crumble leaving bare wires going to the headlights. I first noticed this on my SLK, then on my 06 CLK350. The wires are tight anyway and will ground out. I have tried to cover the bare wires but it caused trouble and headaches Once I got the lights working, tried not to touch them again. Take a look, mine would go off if you hit a bump in the road! Really sad to see this in such a nice car. Took forever to find a replacement for the SLK but have not checked into the CLK harness. I have Halogen lights. Good luck.
 

· Registered
2006 CLK350 Sport
Joined
·
22 Posts
No problem, I bet thats the issue. I tried black tape in a can the 1st time, what a mess! On the CLK I was able to use real black tape but I have ordered all new bulbs cause I think my car has Halogen bulbs. I am new to this platform so dont know much about them, Yet. I plan on installing them, capping them & never touch them again!
 
1 - 10 of 10 Posts
Top