Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
426 Posts
Discussion Starter #1
There is loud flapping sound inside the dashboard when I start the car. I am sure it is coming from the vent door when it shut close. Is vacuum line is leaking or door is gummed up so it need extra vacuum to shut the vent door(pod)? It only happens when I start the car and some time when I switch off the car.

How can I fix it?

Sahai
 

·
Registered
Joined
·
470 Posts
Hi Sahai,

If you suspect vacuum, you can check some of the vacuum lines with a hand-held vacuum pump. I'd try some of the lines leading to the firewall from the engine bay (I can't remember which off the top of my head). Do you think something may have fallen back there? I'd say the sure way to do it is the try the vent selector buttons to see which vent may causing an issue. The horrid answer though...you might have to pop the dash off. You can do it!!!
 

·
Premium Member
Joined
·
1,026 Posts
If your hvac is working correctly, that is default behavior. Defrost vents open when you shut off the car. When you start it, they close. If your vacuum system has a leak, you will never hear this because they default to open all the time. It might be louder than you remember it because all the doors are/were covered in foam rubber that erodes away after all these years. When that's happens, you can really hear them opening and closing.
 

·
Registered
Joined
·
426 Posts
Discussion Starter #5
If your hvac is working correctly, that is default behavior. Defrost vents open when you shut off the car. When you start it, they close. If your vacuum system has a leak, you will never hear this because they default to open all the time. It might be louder than you remember it because all the doors are/were covered in foam rubber that erodes away after all these years. When that's happens, you can really hear them opening and closing.
I agree with you Foolio2!
Everything works as they should. This is what I have noticed. I removed the glove box inside lining to see what happens when the car is started. Vent door was normally open. when I turn on the switch and start the car, door swing to the forward position and shuts the vent opening on passenger side and blower fan did not start. This is were I hear the loud noise. Now,after few minutes when coolant temp. rises the door swing backwards and opens the vent and blower fan starts and blows hot air (It is winter now and climate control dial is set at 22 degree Celsius)- Perfectly normal working, Is'nt Foolio2? I think you are right Foolio2! Vent door rubber lining has become hard or shot. How to renew it? Any idea Foolio2?


Sahai
 

·
Premium Member
Joined
·
1,026 Posts
Yes, it sounds like yours is working normally. As far as renewal, at the very least you have to remove the dash, at the most, the entire heater core! There was actually a thread several months back (don't remember who the OP was but it was very impressive) that goes though many of the steps to do a refresh on the heater core and all its associated moving parts.
 

·
Registered
Joined
·
426 Posts
Discussion Starter #8
Yes, it sounds like yours is working normally. As far as renewal, at the very least you have to remove the dash, at the most, the entire heater core! There was actually a thread several months back (don't remember who the OP was but it was very impressive) that goes though many of the steps to do a refresh on the heater core and all its associated moving parts.

No way JOSE!!!!. I am not gonna do this. Not at this time. Removal of Dashboard is not my cup of tea. I mean, I can do that but at this time No. Some other time.

Sahai
 
1 - 8 of 8 Posts
Top