Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2002 Mercedes-Benz C230 Kompresser Sport Coupe, 6-speed, leather, pano roof
Joined
·
110 Posts
Discussion Starter #1
Hi gang,

I was taking my c230 out for a joy ride (a freind wanted a ride) and during the trip, I lost engine power. We started out of town, I was in third gear, and gave it the juice. She lunged and sped up, grabbed fourth, sped up normally, grabbed fifth, normal power, grabbed sixth, still normal. Now, Im up to 85 now, so I let it gradually slow down. When I push the accelerator, it now hesitated...really hesitated! I downshifted and could put the accelerator to the floor without any immediate response. After a few seconds, she started to respond, but sluggishly. She didnt buck or die, just lost power. From a stop, I have to push the accelerator and wait for the power to come up...maybe 3 seconds. And then, the power is not normal...maybe less than half.

My first thought was "oh crap, the supercharger". I didnt hear a belt come loose, so I looked and it was still in place.

Next thought was "oh crap, the supercharger is smoked". So, I came to this great site of information and think maybe its the MAF or the throttle body. Does this sound correct or am I back to "oh crap, the supercharger is smoked"?

Any input is welcome...

Thanks

Tim
 

·
Registered
1997 W202-C180 Classic, smoke silver metallic, Lowered
Joined
·
271 Posts
6th?
I think you need to post this in the w203 forums (Your car is made in the year 2002)
 

·
Registered
2002 Mercedes-Benz C230 Kompresser Sport Coupe, 6-speed, leather, pano roof
Joined
·
110 Posts
Discussion Starter #3
Sorry about that...Ill move it to the 203 boards. Thanks!
 

·
Registered
1998 c230 170K
Joined
·
1,415 Posts
Yep, wrong slot for forums but wondering if the hesitation will go away upon restart?

Suggestion from here is scan for codes. Yes, it could be one of many things at this point.

I had an issue of floaty or hesitation when driving hard like that with kick down and such and upon restart everything was fine, no codes. Finally found a Throttle position sensor for cheap, replaced, problem solved. B
 

·
Registered
2002 Mercedes-Benz C230 Kompresser Sport Coupe, 6-speed, leather, pano roof
Joined
·
110 Posts
Discussion Starter #5
bmeister,

Funny you mention the restart idea. I was so mad at "Ina Faye" last night, that I parked her and drove my truck to work instead. This evening, I went to move her and lo and behold, the power was back! I couldn't believe it! So, you had a similar issue and a throttle position sensor was the culprit. I will start to look for one. Any suggestions for a place to acquire one on the cheap? Thanks again!

Tim
 
1 - 5 of 5 Posts
Top