Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Hi Guys so recently had a problem with the tensioner however this is fixed and I have just noticed another problem currently.

So feels like the turbo stops working halfway though a drive, turning the car off and back on then fixes is but as I don't have a boost gauge I cant really tell if it has stopped working etc however there's no woosh noise and its very sluggish.

Anyone came across this problem before ? not in limp mode, can rev past 2500 and turning the car off and back on solves it... going to be doing a smoke test soon for the woosh noise as I think there's a vacuum leak somewhere along the intercooler tubing.

Anyone have any thoughts as to what this could be ?
 

·
Registered
Joined
·
404 Posts
M
Anyone have any thoughts as to what this could be ?
I just realized you are in Scotland. You may want to get hold of Dave2302 he is a member who is a mechanic in Scotland. Not sure how much he has dealt with diesels. But he may be able to give you some guidance. I know him from this post https://www.benzworld.org/threads/i-am-dumbo-a-warning-to-others.3029874/

He is NW near Eilean, his is the first post of the above.

I was just in Glasgow this past November. Daughter spent a semister at the University of Glasgow. We had a great time there.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #3
Sorry been off work for the past few days and haven't had a chance to respond.

Ohh, how was Scotland for you enjoy it ? Hopefyly you came when it was warm and not the usual Rain !

Ill give Dave2302 a message see what he things.

Thanks Wallyo
 

·
Registered
Joined
·
404 Posts
We enjoyed it a lot and want to go back,We made it there in November for our US Thanksgiving holiday. A bit chilly but rained only one day. Even got to the Winter carnivals in both Glasgow and Edinburg. If you have never got there, the transportation museum in Glasgow is wonderful (went twice).
 

·
W220 Moderator
Joined
·
5,650 Posts
Hi,

Is this a CDI Engine ? I'm not familiar with the exact model, but I do do a lot of MB and other Diesels.

How far away are you from me, I would really like to run the Car on SDS and that will likely nail it first go. There are so many things it could be it simply isn't worth guessing just one part is likely to cost more than an Hour or even 2 hrs on SDS if it's really involved and needs a load of tests and actuations as well ;)

HTH, Cheers Dave
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
We enjoyed it a lot and want to go back, We made it there in November for our US Thanksgiving holiday. A bit chilly but rained only one day. Even got to the Winter carnivals in both Glasgow and Edinburg. If you have never got there, the transportation museum in Glasgow is wonderful (went twice).
Brilliant 😀😀! Love hearing people enjoyed their time in our wee part of the world. Even more so that it only rained once !! Its always chilly here, why I permanently have a hoodie or jacket on 😂

I haven't been to the Edinburgh one but my parents have and they loved it but ive never been to the new transport museum :( somewhere I will be going once I sort my house out !

If you are ever over again give me a message only 15 minuets from town !
 

·
Registered
Joined
·
72 Posts
Discussion Starter #7
Hi,

Is this a CDI Engine ? I'm not familiar with the exact model, but I do do a lot of MB and other Diesels.

How far away are you from me, I would really like to run the Car on SDS and that will likely nail it first go. There are so many things it could be it simply isn't worth guessing just one part is likely to cost more than an Hour or even 2 hrs on SDS if it's really involved and needs a load of tests and actuations as well ;)

HTH, Cheers Dave
Hi Dave, yeah its the 5 cylinder 2.7 OM612 engine.

Im in Glasgow so wee bit away but would be a good drive !

Huh a few hrs didn't think it would take that long, don't want to take you away from anything :s

Anything you think I should try first etc ?
 
1 - 8 of 8 Posts
Top