Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1991 350SDL 2004 G500
Joined
·
528 Posts
Discussion Starter #1
There are a few issues but I think they are related so a little back story might help with this one.


Couple of years ago my belt/pully managed put a hole in the front engine cover. I had it fixed but the job wasn't done 100% properly and a small amount of oil has leaked from the cover ever since. Last year the belt shock came loose (the rubber wore out) and started to rattle badly at idle. I replaced it with a new one but now this one is starting to rattle as well. Is the leaking oil wearing out the rubber in the shock?

However thats minor compared to what happened today. I pulled over to the side of the road to pick up a hurt robin. When I got back I reversed the car to turn around, when I put it into drive the dash lit up and the car became hard to steer for a few seconds (No power steering) driving home was fine but when I slowed down again it started to act up, it did it again this mourning backing out of the driveway. I know it has something to do with the belt. (Because the last time my dash lit up like that was when the belt snapped and put that nasty hole in the cover) I'm not sure where I should start, any ideas?


(P.S the engine was cleaned last week with engine cleaner and a weak stream from a hose)
 

·
Registered
1991 350SDL 2004 G500
Joined
·
528 Posts
Discussion Starter #3
Aha I figured it out (Well, I figured out the next step at least) Turns out that the power steering pump is putting enough pressure on the belt to stop it at idle. I found out as I drove around our parking lot earlier. Any time I turned the wheel "too far" (I little over half way) the dash lights would start turning on. and stop the belt.
 

·
Registered
1991 350SDL 2004 G500
Joined
·
528 Posts
Discussion Starter #5
Won't have time until I get home later but that will be step one.
 
1 - 5 of 5 Posts
Top