Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1990 300GD (463)
Joined
·
6 Posts
Discussion Starter #1
The last 2 days I have experienced a losing of power when I go up a spesific hill. It is a bit of a climb, probably a gradual 2km climb. It's only the last bit, were the car loses power. It's like it shakes a bit.

i don't know if that is maybe dirty diesel I have in. The my fuel is fairly low, so that might be it.

I was wondering if anyone had experienced a similar problem?
 

·
Registered
280 GE / 1980
Joined
·
458 Posts
If you ever resolve the problem letme know how .

I have the same issue but with 280 GE .

Sometimes if I accelerating on the 1st gear in a hill the truck just looses power and I have to either raise th RPM before i release the cluthc or get into GA .

ReG ,

Shebl
 

·
Registered
85 300GD LWB
Joined
·
501 Posts
I had a similar problem once before... rather embarrassing too... I had bought new floor mats and had to trim them to get them "right". Well for a few days afterwards I notice I could not get the same level of power when going up hills. Turns out a piece of the floor mat got between the accelerator pedal and the stop on the floor....doh!!![:I]

It could be worth looking around to be sure you linkages are unobstructed and that you are actually able to engage FULL throttle. Have you added any weight to your truck. I have noticed that with my 300GD that if there is a full tank of fuel and four passengers with luggage, she is certainly a tad slow on the hills.
 

·
Registered
230G
Joined
·
206 Posts
Shebl - 5/20/2005 6:37 AM

If you ever resolve the problem letme know how .

I have the same issue but with 280 GE .

Sometimes if I accelerating on the 1st gear in a hill the truck just looses power and I have to either raise th RPM before i release the cluthc or get into GA .

ReG ,

Shebl
Shebl, how are u, just to tell you to check your injectors and your spark plugs (and distributor), the 280 really lacks of torque and when and raising the revs is normal in some situations, it's not a V8 [:p], and concerning my 230G low gear is an issue specially when it s fully loaded.
Regards
 

·
Registered
280 GE / 1980
Joined
·
458 Posts
a - 5/21/2005 4:05 PM
Shebl, how are u, just to tell you to check your injectors and your spark plugs (and distributor), the 280 really lacks of torque and when and raising the revs is normal in some situations, it's not a V8 [:p], and concerning my 230G low gear is an issue specially when it s fully loaded.
Regards
You are probably right Anthonny , I am strongly suspecting the injector bcs I am getting a thik black smoke .

But with the few days I get to spend in Lebanon , I don't have much time for repairs especially with the parts scarcity .

So I prefer driving it as it is for the few days I have instead of parking it at the garage .

Maybe on a longer holiday I will have to change the injector system if not swapping the engine .
I would have loved the Mercedes 320 V6 24 valves but it is too costly , maybe the chevrolet 3.5 L , will be my choice , considering the parts and the cost and the experience my friends already has , being done on many off road vehicles .

ReG ,

Shebl
 
1 - 8 of 8 Posts
Top