Mercedes-Benz Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #4
Yes..

Don't forget to mention MBNZ.org Get their catalog as well. It's full of really nice parts and accessories for our cars.<br> <br> Click the link below.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #5
Frank, Under what categories should i choose?

I found lorinser body kits and wheels but not their spring. Please help
 

·
Registered
Joined
·
0 Posts
Discussion Starter #7
Problems

Frank, recently i just install my wheels (LM5 18*8.5 and 18*9.5)to my c320 and i found out that there are some noise (like rubbing noise) on a bumpy road from the rear wheels. Do you know what happen? and yet i havent change my springs
 

·
Registered
Joined
·
0 Posts
Discussion Starter #9
Re: I got the LM5s also but didnt get the 9.5s in the back because I was told they were rub..gu....

Yeah, They wont rub if there are no ppl sitting at the back. So are you using 8.5 for all? did you lower your car? can you post some pics of your car<br> BTW thanks RSG!
 

·
Registered
Joined
·
0 Posts
Discussion Starter #10
Yeah exactly, if I didnt often have people in back I definetly would have gotten the staggered set..

I have not lowered my car yet, but am looking at the H & R Stage 2 Springs. I'll post pics when I finally finish all my mods I'm planning in the near future...btw, what color is your car and what tires did you get? Let me know if YOU post pics...thanks
 

·
Registered
Joined
·
0 Posts
Discussion Starter #12
Re: Yeah exactly, if I didnt often have people in back I definetly would have gotten the stagge....

My car color is obsidian black, and i use 225/40/18 for front and 255/35/18 for rear<br> ill surely tell you if i post some pics. Thanks
 

·
Registered
Joined
·
0 Posts
Discussion Starter #13
Re: Problems

SOUNDS LIKE A BAD OFFSET. I HAVE 19x9.5'S ON THE REAR WITH 265'S WITH NO PROBLEMS I'M DEPLOYED RIGHT NOW, SO I DON'T KNOW WHAT MY OFFSET WAS, BUT I THINK IT WAS A +36 OR +38.<br>
<br>
<br>
ROB
 

·
Registered
Joined
·
0 Posts
Discussion Starter #15
Thats what i think , I think ive got the wrong offset problem

whenever there are 2 people sitting at the back of my car, i will hear the rubbing sound. Maybe i really need to roll my fenders . Thanks for the reply guys
 

·
Registered
Joined
·
0 Posts
Discussion Starter #18
Re: The correct offset for the LM5 is 31.

But i think lorinser gave me a wheel spacer/adapter ? Should i used it? and i thought that the offset for lorinser was 37
 
1 - 18 of 18 Posts
Top