Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
current fleet: 1996 s500; 1997 BMW 328ic; 2000 Nissan Frontier; 1966 AC Cobra
Joined
·
279 Posts
Discussion Starter · #1 · (Edited)
Here is the issue:

The heater hose connector on my 1996 s500 is rubber/plastic. it is a rather complicated looking set of hose connectors - four in all. The plastic/rubber version is cheap and deteriorates. I was told that s600's have an all aluminum version. Particularly the s600's of the early 90's.

Here is the plastic part #: 1408301696

Can you confirm whether or not there is an aluminum version of this part?


I tried to include an image of it on my e-mail but could not. Here is a Benzworld discussion forum link on the matter:
http://www.benzworld.org/forums/w140-s-class/1320788-evil-lurks-under-hood-really-devil-himself.html

Here is an image of the plastic part:





Looking for an aluminum version - please advise


This issue was originally posted in the thread "the devil is under the hood"
 

Attachments

·
Premium Member
2012 E350 CGI Avant Garde Sport, 2011 E350 Avant Garde Cabriolet
Joined
·
1,940 Posts
My '93 500SEL has the aluminum part. You might try that year and see what happens
 

·
Registered
current fleet: 1996 s500; 1997 BMW 328ic; 2000 Nissan Frontier; 1966 AC Cobra
Joined
·
279 Posts
Discussion Starter · #3 ·
thanks for checking and replying

so far all parts lead me back to this part #: 1408301696 - which is the rubber plastic version.

I will keep searching
 
1 - 3 of 3 Posts
Top