Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am pulling my hair out
every one has told me the BT Puck with tail is plug and play on my
2004 E320 4matic wagon - not so fast
the blue tooth puck when plugged in does not light the blue light on it
so I look thru the vast info on the web a decided to dig in
when I removed the com cover in the cargo area I saw two open areas
compinsator?
DSCF4593.JPG (image)
Clueless to what goes in this space, but as you can see I am reading the directions
DSCF4594.JPG (image)
while we are at it what goes above the GPS Drive
DSCF4596.JPG (image)
or below it
DSCF4597.JPG (image)
relay "D" and fuses 17-18-19-20 are missing
DSCF4595.JPG (image)
HELPPPPPPPPP!!!!!!
BTW I added the GPS and SAT Radio my self - can't say enough good things about the MBDoctor
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,429 Posts
I understand this is a US car when you say you have installed the sat radio.

Have you checked if your Tele-Aid unit is powered up? Perhaps it has been disabled completely and fuse of power plug unplugged?

You don't need the antenna compensator with this puck with tail.
 

·
Registered
Joined
·
118 Posts
I would guess that either, as DieselBenz states, the TeleAid had been disabled, a fuse may have blown, or you have an electrical problem.
That puck with tail is designed as a plug and play device, but you still need version coding to enable the CP211 to recognize a phone installation.
 
1 - 3 of 3 Posts
Top