Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello I have a 1975 450sl that upon cold start idles high and then drops low until the engine fully warms up. After reading threads here it seems the culprit would be the AAV valve. Where is the best source to procure one of these, I have found a few used ones on eBay but that seems a bit risky...Thank you so much for your time and response!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you! This seems to be a common part replacement here with very few available options out there besides used!
 

·
R/C107 Moderator
1986 560SL: '84 500SL: '84 280SL 5 speed: other 107s
Joined
·
32,590 Posts
Starts high goes low? That's what it is supposed to do. You can replace just the bulb. AAVpart
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,766 Posts
There are threads in EGzv107 (stickies) under djets on how to dismantle and clean an AAV. That is usually all they need. Sometimes just a good clean will be enough. The valve should be fully closed at about 150F and open and close smoothly. Once car is fully warmed up, idle screw next to AAV should be adjusted so idle is at about 700rpm. Cold start idle will be about 1100-1200 rpm and gradually drop to 700.


We do need to find out about the outfit who are said to be rebuilding AAVs. Not everyone would want to do it themselves.
 

·
Registered
1973 450SL, (Previous 2008 ML350,2002 E320 Wagon, 2000 SLK230)
Joined
·
56 Posts
Sorry to reply so late. So far this is still functioning properly so I am impressed. It was through eBay, and they seem to maintain an inventory(as of tonight it showed 6 available, 27 sold). There was a core charge, and it was refunded VERY promptly which was impressive as I'm in Upstate NY and they're in California. I would normally state who it was, but didn't want to violate any advertising rules on this site. If interested PM me and I'll get you the link.
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,766 Posts
Sorry to reply so late. So far this is still functioning properly so I am impressed. It was through eBay, and they seem to maintain an inventory(as of tonight it showed 6 available, 27 sold). There was a core charge, and it was refunded VERY promptly which was impressive as I'm in Upstate NY and they're in California. I would normally state who it was, but didn't want to violate any advertising rules on this site. If interested PM me and I'll get you the link.
There are no rules that I am aware of against posting ebay links here if you are not the seller.

I did check eBay and saw reman AAVs for $450! Or just used ones for not much less! Crazy prices for what is really just a thermostat. However, our cars do need an AAV in good working condition to function properly.
 
1 - 7 of 7 Posts
Top