Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,410 Posts
Lighting issues in no peticular order can arise on external lighting and bulb out indicator on the dash. Some lights may not come on, all lights can work but bulb out indicator can be lit, bulbs not work and light indicator not be on, all depends on if previous owners rewired and such.

Good Luck.
 

·
Registered
Joined
·
8,119 Posts
Discussion Starter #3
Thanks man! working on no dash or console lighting.so far around 5 hrs spent on this problem.I've pulled inst. cluster ,repaired blown mini fuse on rear of cluster,tested for continuity on circuit board that fuse goes into,its good.
removed rheostat,took it apart soldered connection points .reinstalled still no dash lights? removed two ground connections behind inst cluster opening ,inside on firewall with 8 ground wires attached cleaned grounds still no lights.
removed climate control unit and stereo JVC inspect for loose wires.none found. discoed annt power in trunk.replaced fuses checked for 12v for all fuses good and reseat relays at fuse box .nothing.removed headlight switch sprayed contact cleaner into it .still no lights.
warning lights with key on do work .so its getting power for those
Now I'm going to follow the schematic for illumination cir and test for power.
So it's been fun right!
Just thinking whats the first thing you do to activate lighting? turn on headlight switch! so power starts there.the switch is kind of loose feeling doesn't really snap from one position to another right.maybe that's the problem.need to test output power of switch to cluster.
also read a post wiring from HL switch goes to junction behind ash tray for illumination.I'm going to start swapping parts from my 91 to this 92 see if I can figure it out.everything works on 91
That relay I posted is over 200 bucks! hope its not bad?
read one post .the guy had same problem.but when he opened one of the rear doors.dash lights came back on! wtf!:surrender:

Friend of mine says.maybe if one bulb on illumination cir goes bad they all go out? like Xmas lights? hope not that would totally suck:D
 

·
Registered
Joined
·
8,119 Posts
Discussion Starter #5 (Edited)
$200?!
Damn, looks like I have to raise prices.


and no, if the bulb out light comes on it it's not like xmas lights. it's just that one bulb that goes out.
Thats what I thought too.Autohauz az charge like 235 buckaroo's ridiculous:crybaby2:
Its a good thing I purchased a 91 124 2 weeks ago.lighting all works on it! so I can use it as a parts car for this 92 to help in figuring out the electrical prob I got.I'd like to ring the guy's neck that sold my son this 92 on ebay.so far rebuilt top of engine,cooling system,brakes,tires and wonderful electrical system.a no surprise car as advertized .what a A hole!
 

·
Registered
Joined
·
8,119 Posts
Discussion Starter #6
So more trouble shooting the electrical prob.after looking at the schematic for this circuit.tested grey/purple wire leaving the head light switch have power leaving switch also at multi pin conn at rear instrument cluster where that wire goes to .its for illumination.tested power at top of rheostat nothing.removed rheostat.there's 2 pins it sits on no power. removed small fuse on inst cluster that control's voltage for dash lights solderer it again and tested continuity when its back in the board and had good continuity there .so I guess maybe bad circuit board on cluster
 
1 - 7 of 7 Posts
Top