Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
Discussion Starter #1
Now the "coil" light indicating the glow plugs are ready to start does not light up at all when starting the car. Obviously, it could be the bulb, but what else might cause this problem? Thanks.
Hemersam
 

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
Discussion Starter #3
MBeige: thanks for the reply. I was sceptical about the bulb, given the car only has 57K on it. I almost hesitate (from fear) to ask where the glowplug relay is? I hope it isn't deep in the bowels of the dash, but maybe somewhere in the engine compartment where I can get to it easily??? Do you, by chance, have a picture o description of its location? Thanks again.
Hemersam
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Control unit and relay are one, with part #
 

Attachments

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
^Sorry wrong attachment.
 

Attachments

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
Discussion Starter #6
relay

Eric242340: thanks for the diagram, but it's so small and faint I can't read any of the numbers.
Hemersam
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
On my computer I simply press Ctrl + Alt and + to make it bigger, not sure if this will work on yours, anyway part # is A002 545 43 32
 

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
Discussion Starter #8
R

ERIC242340: my computer will not do the ctr/alt/+ thing (of course). However, thanks for the part number; I'll get on it Monday morning. I think this part is mounted in the engine compartment, fender on the driver's side.
Thanks again.
Hemersam
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
MBeige: thanks for the reply. I was sceptical about the bulb, given the car only has 57K on it. I almost hesitate (from fear) to ask where the glowplug relay is? I hope it isn't deep in the bowels of the dash, but maybe somewhere in the engine compartment where I can get to it easily??? Do you, by chance, have a picture o description of its location? Thanks again.
Hemersam
Could be the strip fuse inside the relay. Maybe a bad GP too. Not sure how different it is from the W123 diesels. Check the easy solutions first before ordering a new one.
 

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
Discussion Starter #10
190d

Problem solved: two glow plugs "going bad." Apparently, all four plugs were originals (car has 57K), I replaced them all, and everything works great now. Thanks, everyone.
Hemersam
 
1 - 10 of 10 Posts
Top