Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hi, I have a `91 300 TD Turbo(Euro/Norwegian).
OM603.960 engine
I ofcoarse have trouble with leaks around the prechambers, some small leaks at cyl 3 and 4, but after I checked my nozzles, I`ve got a decent leak at cylinder 1, It`s squirting diesel out of the half-moon next to the prechamber-locking-nut, and the engine runs om 5 cylinders at idle.

I have ofcoarse checked the nozzle/injector, changed the injector seal ring. But Cant find anything.

I have bought a socket with the correct splines(KLANN KL-0369-3), and will try to pull them out tomorrow, but I dont have the grinding tool, or shims, I`m going to make a tool for pulling out the prechamber from a used nozzle.

Do you have any tips forr me, what I should do, how?
I`m thinking about using a thin copper or aluminium washer for the seal if I need to, and maybe take a little cut in the prechambers to keep correct position of them.

Do you have anything for me, experinces, other stuff.

Thanks from Norway...
 

·
Premium Member
Joined
·
10,116 Posts
Hi, I have a `91 300 TD Turbo(Euro/Norwegian).
OM603.960 engine
I ofcoarse have trouble with leaks around the prechambers, some small leaks at cyl 3 and 4, but after I checked my nozzles, I`ve got a decent leak at cylinder 1, It`s squirting diesel out of the half-moon next to the prechamber-locking-nut, and the engine runs om 5 cylinders at idle.

I have ofcoarse checked the nozzle/injector, changed the injector seal ring. But Cant find anything.

I have bought a socket with the correct splines(KLANN KL-0369-3), and will try to pull them out tomorrow, but I dont have the grinding tool, or shims, I`m going to make a tool for pulling out the prechamber from a used nozzle.

Do you have any tips forr me, what I should do, how?
I`m thinking about using a thin copper or aluminium washer for the seal if I need to, and maybe take a little cut in the prechambers to keep correct position of them.

Do you have anything for me, experinces, other stuff.

Thanks from Norway...
Not to turn you away, but I think this site offers a forum just for diesel MB owners, although many are in here as well. I stumbled into a discussion once in there about compression leakdown testing. Check it out.:thumbsup:

Kevin
 

·
Cruise Control
Joined
·
52,233 Posts
Did you install new pre-chambers? Sometimes these will interfere with the bosses in the head, which requires some machining to ensure a tight seal.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4
The prechambers in my head have been there from the factory, but I got a hell of a leak after disassembling the injectors(Checking spray pattern/pressure).
But I may change them, I got a Spare head with cracks, so if it`s somthing wrong with them I`ve got 6 "new ones".
 

·
Cruise Control
Joined
·
52,233 Posts
So, you didn't remove the pre-chambers at all, and just had the injectors out--right? Are you sure the injector heat shields are installed correctly, with the curved surface facing downward? I can't imagine how diesel could possibly make its way out around the outside of the pre-chamber.

Years ago I installed a new cylinder head and had a couple of pre-chambers leak combustion gases around the outside. So, I removed them and ground off a little bit of the surface where they were interfering with the head.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #6
The injector seal ring is correctly mounted as you describe, also tried to change it, the engine is not running on cylinder 1 at idle after this, I think that is why it "squirts" diesel.
i tried disassembling them on my old cylinder head, but i Need some longer tools, not enought power.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
The problem is fixed for now.
The prechamber nut was loose, a bit cleaning, w/o removing the prechamber, and a good tightening, and the problem was gone, :)

But I have the normal leak at a couple of other cylinders, so any tips is great.

Have a Nice day....
 

·
Registered
Joined
·
2 Posts
Hei,

Jeg har en mb124 300 TDT fra 91, med samme problem som du hadde. Hos meg lekker det eksos fra en av sylindrene.

Har kjøpt pipen for å kunne ta ut forkammeret, (samme som du har kjøpt) men mutteren sitter bom-fast. Er nå litt usikker på om jeg ikke har fjernet nok før jeg prøver.

Har tatt ut dysen og glødeplugg fra denne ene sylinderen, ellers har jeg ikke fjernet noe. Må man fjerne topplokket for å kunne ta ut forkammeret?

Tipper at det hos meg er tetningsringen under forkammeret som er skadet. Fikk tak i ny ring.

Om du heller vil ringe, du når meg på 92200314.

All nyttig info er velkommen :)

Hilsen Rob.

--------------------------------------------------

Hi, I have the same problem but are not able to loosen the pre-chamber nut. Could you contact me?
 
1 - 9 of 9 Posts
Top