Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
484 Posts
Discussion Starter #1
Where it is located in the car? It is posible to change it myself?

The reason for change it is the BAS ESP light that appears occasionaly. I just change the brake light switch.

Thx!
 

·
Registered
Joined
·
2,398 Posts
When is it on ?

It will come on if your losing grip, As the TC cuts in the light comes on.
 

·
Registered
Joined
·
484 Posts
Discussion Starter #9
I`m going crazy!!!! I`ve cleaned the speed sensors but the BAS ESP light keeps switching on and off. It`s seem that, going on rugh terain or claiming sidewalks trigger it. I`ve conected the car to a code reader but no code is generated! WTF????
 

·
Registered
Joined
·
484 Posts
Discussion Starter #10 (Edited)
Got the car rescaned today: three error codes.

C1140 - Steering angle not centered (or something like that)
C1142 - ABS Lateral Acceleration Sensor Open/Shorted
C1202 - ????

I manage to clear them but right after clearing them, C1142 apeared again.

I left the service with ESP BAS light on and got home. After one hour, when i left the home, the light was off. Drived 200miles with no light. Got home again, turn of the engine. After 30 minutes, when i start the engine again, the light was on. What makes it go on and off like that? Can I repair that Lateral Movement Sensor or i must replace it? And if i have to replace it, where in the car is exactly?

PLEASE HELP!

@papa: when i say "BAS ESP light" i don`t mean the triangular yellow light that appears when tyres lose grip but the ones that shows you that is something wrong with the system (like check engine light)

Sorry for my English, learned French and German in school (and i can`t speak none :))
 

·
Registered
Joined
·
484 Posts
Discussion Starter #11
I`ve just removed my center console. Unplug and then plug again the sensor. Everything is now OK. So watch out for services that charge you for "replacing" the sensor! First try to fix it yourself, it could be a bad contact.
 

·
Registered
Joined
·
6,821 Posts
I`ve just removed my center console. Unplug and then plug again the sensor. Everything is now OK. So watch out for services that charge you for "replacing" the sensor! First try to fix it yourself, it could be a bad contact.
So you finally read my post :eek:
 

·
Registered
Joined
·
1 Posts
I`m going crazy!!!! I`ve cleaned the speed sensors but the BAS ESP light keeps switching on and off. It`s seem that, going on rugh terain or claiming sidewalks trigger it. I`ve conected the car to a code reader but no code is generated! WTF????
Hi There,

Did you ever resolve the problem?
 
1 - 13 of 13 Posts
Top