Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
mercedes 2002 e320 4matic
Joined
·
4 Posts
Discussion Starter #1
When turning on headlight switch to first or second position, the warning light goes on. This first started when one of the front lights went out. Mechanic has replaced headlight switch and module and rear brake lights and sockets. It is still going on!! Any advice. Its driving us nuts and costing a fortune already.
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
Welcome. Please click user cp and edit details to add your vehicle and location to your profile, it's often useful information.

The most obvious is to check the license plate bulbs, as in plural. There are two of them, and if one burns out, you get the error, but it's not obvious because the light is still on. And certainly be sure you check every single exterior lamp when the switch is in the first position, although you can ignore the low and high headlight bulbs.

If both of your license plate bulbs are okay (and if they are not your mechanic owes you some money, which he really does anyway because it's not related to the brake lights or the headlight switch) then check the sockets and wiring for the city lights (the small lights on the front of the car, each houses two bulbs, the city light (H6W) and the high beam. Those can corrode and crack, which leads to problems like this.

If not you have to inspect the lamp holders and connections on the PCB boards for the taillights. It may be necessary to build up some solder on the connections. These things are discussed in the stickies and elsewhere in this forum. Not the most common issue, but a troubling one.

Good luck.
 
1 - 2 of 2 Posts
Top