Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1984 MERCEDES-BENZ 300 TURBO DIESEL, 1978 CHEVROLET K20 CUSTOM DELUXE
Joined
·
365 Posts
Discussion Starter #1
Hello, a couple of days ago i was driving down the taconic state parkway. The car felt a little different but i wasn't going that fast so i didn't think anything of it. I then got onto the ramp to merge onto i 84 and i floored it and it did nothing. The speed stayed at 40mph and didn't move. The engine would rev up but it took a while to get up to 70mph. It was also surging a little while i was accelerating. I think its just a clogged fuel filter as its fine up to 30mph. So is this a symptom of a clogged fuel filter.
 

·
Registered
83 500SEC, 84 300TD, 86 190E 5.0 M113, 87 300D, 01 CLK55, 02 C32, 02 C320T, 03 C320T4, 03 E55
Joined
·
2,600 Posts
It can be, yes. main and pre filters, tank strainer, clog in the line, rusted out line, injection pump sucking in air, all can contribute to your description. if it started shifting funny as well, check the boost pressure line from your intake manifold to injection pump for leaks.
 

·
Registered
1984 MERCEDES-BENZ 300 TURBO DIESEL, 1978 CHEVROLET K20 CUSTOM DELUXE
Joined
·
365 Posts
Discussion Starter #3
Ok cool thanks. I ordered a couple of fuel filters and pre filters. one for new and one to keep in the car as a spare. When i take the strainer out of the tank is the fuel thats in the tank going to come out. If it is and i think it is i have the car on r but the light has not come on yet. How many gallons do you think i have left.
 

·
Registered
1984 300D
Joined
·
5,070 Posts
Hello, a couple of days ago i was driving down the taconic state parkway. The car felt a little different but i wasn't going that fast so i didn't think anything of it. I then got onto the ramp to merge onto i 84 and i floored it and it did nothing. The speed stayed at 40mph and didn't move. The engine would rev up but it took a while to get up to 70mph. It was also surging a little while i was accelerating. I think its just a clogged fuel filter as its fine up to 30mph. So is this a symptom of a clogged fuel filter.
It is very easy to get a bad load of Fuel that plugs up your Filter or have something start growing in your Fuel Tank.

Look at the Plastic filter. If it is full of grayish Black slimy stuff you have something growing in the Tank.

This was also mentioned; at the very end of the Intake manifold is a Banjo coneection and Bolt. If that gets plugged the Fuel Injection pump does not get the manifold pressure to give the Engine more Fuel to match the Turbocharger Boost pressure.

Bot issues can have similar symptoms

You did not say if there was any smoke when your problem was happening?
 

·
Registered
1984 MERCEDES-BENZ 300 TURBO DIESEL, 1978 CHEVROLET K20 CUSTOM DELUXE
Joined
·
365 Posts
Discussion Starter #5
I always keep the banjo bolt and line clean and clear. I had no smoke when flooring it and i definitely have stuff growing in my tank. the previous owner never drove it during the winter so it sat for a while every year with fuel in the tank. my pre filter is pure black. Also when i take the tank strainer out how many gallons will come out if it is on r but the light has not come on yet.
 

·
Registered
1984 300D
Joined
·
5,070 Posts
I always keep the banjo bolt and line clean and clear. I had no smoke when flooring it and i definitely have stuff growing in my tank. the previous owner never drove it during the winter so it sat for a while every year with fuel in the tank. my pre filter is pure black. Also when i take the tank strainer out how many gallons will come out if it is on r but the light has not come on yet.
I don't know how much is left in the Tank even when on R. I doubt the accuracy of the Tank Sending Unit and Gauge as old as they are.

Pulling the Tank and cleaning it is one way to deal with it but you still need treat your Fuel with a chemical in order to kill the infection.

Many Forum Members have used a Startrol product made for that purpose; but, there are other Biocides that will kill the organisms.
For more info:
Repair Links
DIY Links by Parts Category - PeachParts Mercedes ShopForum

PeachPartsWiki: Do It Yourself Articles - Mercedes Vehicles
 
1 - 6 of 6 Posts
Top