Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1995 E280
Joined
·
84 Posts
Discussion Starter #1
My 280 make a certain klanking noise in the engine when I accelerate. Some times it drives fine and then from no where the noise comes back. Where should I start from? It has done over 200K miles.
 

·
Registered
'84 300D/ dakota benz trk. Sold... miss it. "88 260E '91 190E 2.6 '89 Volvo 240DL "85 300D
Joined
·
1,252 Posts
are you sure its coming from the engine bay? sounds more like it could be a worn drive shaft carrier bearing, bad half shaft, or maybe worn flex plate.
if it is coming from engine bay and only does it under acceration, it MAY be loose TC bolts. but i doubt that.
 

·
Registered
1995 E280
Joined
·
84 Posts
Discussion Starter #3
are you sure its coming from the engine bay? sounds more like it could be a worn drive shaft carrier bearing, bad half shaft, or maybe worn flex plate.
if it is coming from engine bay and only does it under acceration, it MAY be loose TC bolts. but i doubt that.
Thanks for your reply
It only happens under acceleration. And some days it does not happens. Iam making a printout of your reply will show it to my mechanic since Iam going for general service. What is TC by the way?
 

·
W124 Moderator
86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Joined
·
12,686 Posts
TC = Torque Converter. If the "klanking" noise is only under acceleration your likely problem area is in the drivetrain as Mountainredneck mentions. Have your service tech check all the mounts, shafts, carrier bearings, bushings etc.

Good Luck,

Jayare
 
1 - 4 of 4 Posts
Top