Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I am now starting to look into the Keyless Go and Keyless Engine Start issues on the 05 S55 I purchased last year. These never worked when I bought the car. Here are the symptions:

When I put my hand on the door drivers handle the doors don’t unlock, nothing happens.
When I press and hold the unlock button on the key fob very close to the door handle, the windows do go down.
When I press the little black button on any of the door handles nothing happens. The right rear door rubber black piece is missing as seen in the pic.
When I press the engine start button, it doesn’t start and most of the time I see no message. I took out the button from the shift knob and put it directly into the shifter I saw “key not recorgnized” message breifly then it went away and I saw nothing. I did press my foot on the pedal although, I can start the car with the key without putting my foot on the brake pedal without any issues. One of the pins has half a leg but fits into one of the holes. Tried to upload the picture but the format was different because I airdropped it onto my laptop.
The key fob unlocks/locks the car doors by pressing the unlock/lock buttons and also opens the trunk.
I've tried using the scanner tool but don't get any error codes. I've replaced the battery in the key fob (only fits one battery) and nothing happens.
Did some research but some were able to fix the issue by replacing the key fob battery. I have tried changing the actual car battery as of yet.
The last picture is the rear window radio antenna which is missing a cover. Not sure if that is part of the issue but adding it.
Instead of throwing money on parts I was hoping to get some guidance on what to start with then move on from there.
Adding some pics if helpful. Bumper Automotive exterior Automotive design Personal luxury car Vehicle door
Hood Motor vehicle Automotive lighting Automotive design Automotive exterior
Gear shift Automotive tire Vehicle Motor vehicle Gauge
Motor vehicle Rectangle Hood Gas Water

Thanks in advance.
 

·
W220 Moderator
Joined
·
8,561 Posts
Is it possible that your Key is not a KG Key ?

Or a new one that is KG but is assigned to the wrong Tracks in KG Module ????????????
 

·
W221 & Audio Moderator
Joined
·
710 Posts
I am now starting to look into the Keyless Go and Keyless Engine Start issues on the 05 S55 I purchased last year. These never worked when I bought the car. Here are the symptions:

When I put my hand on the door drivers handle the doors don’t unlock, nothing happens.
When I press and hold the unlock button on the key fob very close to the door handle, the windows do go down.
When I press the little black button on any of the door handles nothing happens. The right rear door rubber black piece is missing as seen in the pic.
When I press the engine start button, it doesn’t start and most of the time I see no message. I took out the button from the shift knob and put it directly into the shifter I saw “key not recorgnized” message breifly then it went away and I saw nothing. I did press my foot on the pedal although, I can start the car with the key without putting my foot on the brake pedal without any issues. One of the pins has half a leg but fits into one of the holes. Tried to upload the picture but the format was different because I airdropped it onto my laptop.
The key fob unlocks/locks the car doors by pressing the unlock/lock buttons and also opens the trunk.
I've tried using the scanner tool but don't get any error codes. I've replaced the battery in the key fob (only fits one battery) and nothing happens.
Did some research but some were able to fix the issue by replacing the key fob battery. I have tried changing the actual car battery as of yet.
The last picture is the rear window radio antenna which is missing a cover. Not sure if that is part of the issue but adding it.
Instead of throwing money on parts I was hoping to get some guidance on what to start with then move on from there.
Adding some pics if helpful. View attachment 2732745 View attachment 2732746 View attachment 2732747 View attachment 2732748
Thanks in advance.
A fellow S55 Kompressor owner. One of the most overlooked of the M113k platform.

Any KG feature, when actuated, of course most be from the vehicle side. The vehicle through many antennas will transmit an authorization request to a key in proximity, to perform the desired function. The LED on the key will flash one time if it receives a valid request it will respond and the car will respond. There are KG specific SmartKeys and standard ones. If you have attempted the KG function and they do not work, it is possible the key are keys assigned to the car are not KG keys, or they are assigned the wrong KeyTrack in the EIS/Keyless Go control unit. The Antenna should not affect KG operations as there are many located in the interior, as well as the trunk. You can hear a faint noise when perfectly quiet, that sounds like insects that are emitted from the antennas. They are very quiet and difficult to hear unless the windows are up with not loud noise outside. Each antenna "fires" sequentially in a circular motion when the antennas are seeking a key. This would conclude the antennas are working. They are faint, but it is something you can try.

The W220 M113k is such an overlook model, but one of the best IMO. 27x,xxx mi and counting!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Thanks for the reposnses Dave2302 adn TiffanyTwisted. Very helpful.
So it sounds like I may have the wrong type of key. How would I be able to check if the key is assigned a track in the Keyless Go module or EIS/Keyless go control unit? Is that the same as the Keyless go control module or a separate unit? Sorry still learning...

Btw TiffnayTwisted congrats on the long term ownership of the S55 :cool:
 

·
W220 Moderator
Joined
·
8,561 Posts
Is that the same as the Keyless go control module or a separate unit?
Same.

You will need to have SDS and a good operator to do this ;)
 

·
W221 & Audio Moderator
Joined
·
710 Posts
Thanks for the reposnses Dave2302 adn TiffanyTwisted. Very helpful.
So it sounds like I may have the wrong type of key. How would I be able to check if the key is assigned a track in the Keyless Go module or EIS/Keyless go control unit? Is that the same as the Keyless go control module or a separate unit? Sorry still learning...

Btw TiffnayTwisted congrats on the long term ownership of the S55 :cool:
Thanks! I have an array of MBs to choose from when I am getting ready to drive somewhere - for dinner, work, or a vacation- 1986 300E with 45k miles, a 2008 S600 with 39k miles, a 2001 E320 4m with 190k, a 1999 S320 with 119k miles. And I must say, I always go to the S55 when practical. It is one of the smoothest and most fun vehicles I have, and I don't even have to worry about racking up the miles on it!
 
1 - 6 of 6 Posts
Top