Mercedes-Benz Forum banner

Just bought 87 190E...very rough idle/no accel.

1250 Views 5 Replies 1 Participant Last post by  Guest (MBNZ)
It has about 200,000 miles from my best guess. It idles really rough and when u hit the gas it kinda sputters for a little bit then takes off. Freeway driving seems normal. Almost feels like it will die at a stop but it fights for survival. I think a new fuel filter and something to help clear the fuel injection nozzles might help. Are there any suggestions??
1 - 6 of 6 Posts

· Registered
Joined
·
36,559 Posts
Discussion Starter · #2 ·
Get a full tune up to start off. Service the fuel system, I'd get it flushed. Make sure oil is good, timing is correct, idle speed is correct, etc. Just make sure everything with the engine is all good. Just hope there's nothing wrong with the engine phyiscally (cracked head, etc). Get her running nicely and maintain it relgiously it will run very well for years to come!
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #3 ·
A couple things that could cause this if the car is tuned properly and you have cleaned injectors, etc.:<br> -Vacuum leak (cracked rubber hoses could cause a leak).<br> There is a little black rectangular box that goes connected to the air intake (not the filter housing, actual intake) that might need to be changed (its an expensive Bosch part). <br> Possibly change the EGR...
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top