Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi i have a 1999 s500 and recently i have a problem with the battery.
But my battery is drained by the cold.
After starting the car i have tested the battery andeverything was fine.

but that is not the problem.
I have bougt a jumpstarter but i have heard crazy stories that it can blow your ECU. Is that true ??

And how can you use the jumpstarter under the hood, i don't see posive place under the hood.
 

·
Registered
2001 E55 AMG
Joined
·
3,294 Posts
It HAS to be surge protected,whether it's a power pack or jump leads or you WILL fry your ECU..............On the inner wing there is a little black box with a red cross.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
where can i find that black box i have searched everywere but can't find it.
Can i use the jumpstarter on the battery positive and negative connection ?
 

·
Registered
2001 E55 AMG
Joined
·
3,294 Posts
where can i find that black box i have searched everywere but can't find it.
Can i use the jumpstarter on the battery positive and negative connection ?
I might be getting models mixed up.....if your battery is under the bonnet then there is no box....yes you can use the battery terminals,but remember about the surge protection!!!!
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
There may not be a connection under the hood on this car, connect to the battery direct but connect negative first. If it causes a surge, then quite a few modules will fry.
 
1 - 6 of 6 Posts
Top