Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
1979 280SL, 1984 280SL
Joined
·
5,732 Posts
Good luck, John. I'm sure everyone here wishes that bad 107 was theirs. I know I do!

Chief
 

·
Outstanding Contributor , Bob's Your Uncle!
83 280 SL- 5 speed-The PIG
Joined
·
31,110 Posts
It's a great thread, everyone.
Even Ussun will get it because there are lots of PICS.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
11,910 Posts
Discussion Starter · #4 ·
Well it sort of starts. I believe I have dirty fule injectors from it lying around for over a year. Starts run for a second and dies.
 

·
Outstanding Contributor , Bob's Your Uncle!
83 280 SL- 5 speed-The PIG
Joined
·
31,110 Posts

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
11,910 Posts
Discussion Starter · #8 ·
Well not to much better but it does still steadily increase its run time. It ran long enough to be able to rev it occasionally. It's nice to know the electronic throttle actuators work. But still 2 seconds at most. See the video.

YouTube - M120 into 560SL, 107
 

·
Registered
1978 280slc
Joined
·
3,203 Posts
Wow that is crazy cool! It looked like spaghetti coming out of the dash. What a wild project, better watch out when it does start and run hate to read an article about a madman put a V12 into one of these cars and broke the sound barrier.

Did you have to change and strengthen the chassis and suspension? Wow, I wish you the best of luck and the only advice I could offer is when it's done don't let anybody know it's got a huge engine in it with modern goodies, no badges or anything. If they ask just say you have a low compression V8.

Good luck!
 
1 - 9 of 9 Posts
Top