Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
MB E350 4Matic; P2, AMG Wheels; Driver Assist
Joined
·
43 Posts
Discussion Starter #1
Hi Folks - Just took delivery about 2 weeks ago of a 2011 E350 4matic ...white sport with package 1&2, AMG wheels and driver assist. I'm a bit disappoint with the Ipod connection. I have 2 Nanos...a 2nd and a new (5th generation). The older Ipod charges in the benz, but every time I turn on the car, I need to unplug it and reconnect it again for it to work. The newer one doesn't charge. There doesn't seem to be a way to turn either off and leave them connected.

What are some other impressions? Is there a setup (even with another MP3 player) where one can stay connected and turn on/off?

Great car otherwise.

Jim Eash
 

·
Registered
Joined
·
8 Posts
I got my E 350 Lux Pkg 1 4 matic about a month ago. I also use my older nano but it charges fine. I leave it plugged in all the time with no trouble. It uses the flat wide ipod connection. Is yours the same? You could always break out the manual or call the dealer. I have to say my MB dealer has been wonderful to deal with and has answered any questions that pop up. Good luck! Keep us posted.
 

·
Registered
2016 E250 BlueTec
Joined
·
20 Posts
You need to get the newer iPod cable, not the one that has two cables off the connector. I have a 4th generation Nano and when I plug it in it displays a message that says charging is not supported, but it charges anyway and works just fine. I used it on a long road trip and I had no problems.
 
1 - 3 of 3 Posts
Top