Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
1988 560SL. The wiper intermittant system is not working. All other functions (two manual speeds) work just fine. I replaced the Relay but still does not work. I have read that either the switch in the stearing column is bad or there place where the wires attach to the motor needs to be cleaned and re-installed. Does anyone know where I should look. If so can you tell me how to get at the part, location of the wiper motor or how to get the column switch out and replaced.

Thanks

Bud
 

·
Registered
1984 Euro 500SL
Joined
·
107 Posts
I'm not sure about your inquiries but my 1984 500SL is lacking intermittant cycles as well. Could it be that the 2 speeds are all there are? (One of the few complaints I have about the car). I do however try to never drive it in the rain. Do other SL owners have more than the 2 speeds??
Mike
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
When I got the car the intermittant wipers worked fine. The just stopped working about a year ago. I have read that pre 1988 did not have them.

bud
 

·
Registered
Joined
·
53 Posts
I have a 1986 560SL which I inherited and I have done a lot of reading up on 'em since. pre-1988 560SL did not have intermittent wiper options.

To answer the question about your intermittent wiper not working: There is a relay that controls the intermittent feature. i am not quite sure where it is on these cars but if you can get a hold of a repair manual it is a simple fix. On japanese cars the relay is normally underneath the dash and it is about the size of a color cartridge for your injet printer.

hope this helps...

JC
Irvine, CA
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
JC
Thanks for the advice. Unfortunately as I stated in my initial post, I have already replaced the relay, first thing I thought of when it stopped working, but to not avail.

I think I read somewhere, have not been able to locate the article, that there is a contact at the top of the wiper motor that needs servicing. I think the motor is under the dash but am not sure nor to I know how to get at it. Need some help.

Bud
 

·
Registered
Joined
·
13 Posts
I fixed this in my 82 500SL. There was a broken wire in the 14? pin connector for the steering column stalk - maybe you have a similar fault in yours.

Andrew
 

·
Premium Member
2002 CLK 430 Convt. '91 420 SEL, '80 240D, '93 190E Sportline, '70 300 SEL 6.3
Joined
·
1,555 Posts
jomac915 said:
I have a 1986 560SL which I inherited and I have done a lot of reading up on 'em since. pre-1988 560SL did not have intermittent wiper options. ......


JC
Irvine, CA
Why do I have the factory option on my '87??
 

·
Premium Member
1973 450SL 2004 E320 4Matic Wagon 2019 Jeep Grand Cherokee
Joined
·
3,193 Posts
73 had them

My 73 has them. Controlled by a rocker switch on the stalk.
 

·
Registered
71 280se 3.5 Cab, 06 C230, 06 ML350
Joined
·
628 Posts
jomac915 said:
I have done a lot of reading up on 'em since. pre-1988 560SL did not have intermittent wiper options.
I just got back from a trip and wanted to wait to check my car to be sure before posting.

I have an 86 560SL and it definitely has the intermittent wiper option on it.

Hope that helps
 

·
Registered
1982 300D
Joined
·
8 Posts
Need help from some SL guys

question about your intermittent wiper not working: There is a relay that controls the intermittent feature.
Hi, I was hoping to see if one of you SL guys could help me.

I've designed a little electronic module that upgrades the relay that controls the intermittent wipers. It allows the intermittent delay time to be programmed and changed on they fly; anywhere from 3 seconds to 30 seconds. No wiring changes to the car, uses the existing stalk switch - strictly plug and play.

It works well in the W123 and W126, but I don't know anyone with a W107 to help me test it.

Anyone willing to help?

Thanks,
 
1 - 10 of 10 Posts
Top