Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
91 300e
Joined
·
25 Posts
Discussion Starter · #1 ·
Hi All,

I've had my '92 300SL for only about two months now. I absolutely love it. Its arctic white with palomino interior, and it has 63K miles (sorry, no pix yet).

The problem is that occasionally it won't start - meaning the starter doesn't engage at all. The dash lights come on and they don't flicker or dim. It's just that nothing happens when I turn the key all the way to start. No sound, nothing, nada.

The first time it happened it started on the next try, and I gave it no more thought. Then one day it did it when I stopped for gas. I must have tried it 30 times. I was just about ready to call for a tow when it started.

It took it straight to my mechanic, and like a dog that won't do tricks, it started fine for him every time. And it kept starting fine for another two weeks. Then another episode like the first.

I know it's not due to the shifter - I have tried holding the key in start and moving the shifter back and forth from Park to Neutral with no change.

It's starting ok right now, but I want to find out what this is before I get stranded somewhere. And I'm not real keen on just replacing parts until it's solved.

Has anyone had this problem? Any ideas on where to start looking?

Thanks,
 

·
Registered
Joined
·
5,392 Posts
Yup. I am having the same problem now. It could be your starter switch going bad. It has been a very common failure lately.

I was just about to start work on my starter switch and I noticed my battery needed over 240 cc water in each cell. The battery is five years old and it may be my culprit. The car is on trickle charger now. I happened to notice I have no map lights.

However, here are some information to help you out:

http://www.mercedesshop.com/shopforum/showthread.php?t=145316

http://www.mbworld.org/forums/showthread.php?t=141334

Good luck and let us know how you make out.
 

·
Registered
1990 500SL
Joined
·
146 Posts
i had to have the ignition switch replaced twice on my car since new. Mercedes has told me they fail easily if you keep several things on your keyring. they cant take the added weight, and fail
 

·
Registered
91 300e
Joined
·
25 Posts
Discussion Starter · #4 ·
Thanks for the ideas, guys. I did have to replace the ingition switch on my SEL awhile back, but that was due to the key not turning - just like using the wrong key. It does make sense that the ig switch could be the problem. That may be the place to start.

There were a couple of interesting suggestions I gleaned from the links you gave. One was to turn everything off, and exit the car, then lock and unlock the door. It resets the security system. The other was to move the steering wheel up/down and in/out. The next time it happens I'll try both of these and let you know if either works.

Cheers,
 

·
Registered
Joined
·
5,392 Posts
Any update on your problem?

Mine just not starting at all, regardless of trying everything. I am in the process of replacing the starter switch. Hope that will take care of the problem.
 

·
Registered
91 300e
Joined
·
25 Posts
Discussion Starter · #6 ·
It happened again - only this time the car wouldn't start despite repeated attempts. So I had it towed to my mechanic. He diagnosed the problem as the starter switch. $350 later it seems to be working fine. Hopefully this is the end of it.
 
1 - 6 of 6 Posts
Top