Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
SLK32 AMG
Joined
·
593 Posts
Discussion Starter · #1 ·
my 2003 SLK 32 AMG has started to intemittently lose boost power. I dont know if the pool of water underneath is a/c water or a leak.
At random intervals,I boot it and it doesnt zoom off..I thought i had it figured today-i was in W,switched to S and power came back.Minutes later,no power on kick down.
My MB dealer,Autohaus,Pompano FL says no openings for 2 weeks and no loaners(MB or Enterprise) till 26th,do I drive it or have it towed in?
Adrian
 

·
Registered
2002 SLK 32 AMG, bone stock. 1987 190E 2.3-16 valve (destroyed). 2005 E320 new toy.
Joined
·
14,926 Posts
There seems to have been a few intercooler pump failures reported lately.........

You could have that problem. I doubt that you need to have it towed, but if it is that water pump you will not have much power until it's replaced.
 

·
Registered
SLK32 AMG
Joined
·
593 Posts
Discussion Starter · #3 ·
RE: There seems to have been a few intercooler pump failures reported lately.........

Service advisor will try to get me in tomorrow...he laughs at the thought of an internet diagnosis of intercooler /pump /sensor failure-never heard of this!Its prob an acellerator position sensor,he says!
Adrian
 

·
Registered
Joined
·
1,047 Posts
rage2 had a problem of a cracked weld on the bottom of the intercooler that was leaking coolant....

and causing the power loss. That would definitely explain the leak under the car.
 

·
Registered
2003 SLK32 AMG
Joined
·
813 Posts
RE: There seems to have been a few intercooler pump failures reported lately.........

adrose - 4/10/2006 6:03 PM

Service advisor will try to get me in tomorrow...he laughs at the thought of an internet diagnosis of intercooler /pump /sensor failure-never heard of this!Its prob an acellerator position sensor,he says!
Adrian
Don't know about the "sensor" part, but my pump failed the day after I got the car (used). As it is a known fault, and they had replaced their share, they had the AMG part on hand and replaced under warranty. Like you, no real power when it failed. Sometimes it's only the fuse though(also a known issue). Surprised the SA never heard of this [?]
 
G

·
http:/Its prob an acellerator position sensor,he says!/

If this is true, it would definitely give you a check engine light. This happen to my CL 55. Mercedes don't just sell the sensor itself, you have to buy the whole accelerator paddle around $200.

It sounded like it the intercooler pump. This is a normal problem for the C32 and Slk 32.
 

·
Registered
E46 M3 Cab, MKV GTI, NCP91 Yaris
Joined
·
649 Posts
Here are the symptoms of a failing/leaky intercooler:

- Random loss of power (S/C disengaging for about 1-2 mins), confirm using OBD2 scanner and looking at IAT and seeing it spike hard under boost.

- Loss of coolant

- Puddles of coolant (leak externally)

- White smoke out exhaust at startup (leak into intake)

- Hard to start (leak into intake)

- Check Engine Light for Cat issues, misfires (leak into intake). There are no check engine light errors for externally leaking intercoolers.

And here are some pics:

http://www.virgeweb.com/pix/s/dscn4231.jpg

http://www.virgeweb.com/pix/s/dscn4216.jpg

http://www.virgeweb.com/pix/s/dscn4217.jpg

Both my car and kenny's car suffered a failed IC, mine leaked into intake, his leaked outside. The pics are from an externally leaking IC.

Getting a new IC isn't easy... it took about 6 weeks for one to arrive from germany for kenny's, and another 3 weeks for mine. Nobody really stocks them.

Our theory of the failing IC is because we winter drove our cars. Both cars started to lose coolant shortly after we drove the cars out in -40C weather for a week.
 

·
Registered
2002 SLK 32 AMG, bone stock. 1987 190E 2.3-16 valve (destroyed). 2005 E320 new toy.
Joined
·
14,926 Posts
It's amazing how they can get ....................

10 pounds of poop in a 5 pound bag isn't it?
Very nice installation for a watercooled intercooler.[:D]
 

·
Registered
SLK32 AMG
Joined
·
593 Posts
Discussion Starter · #11 ·
update

Took the car in on Tuesday.I had NO compressor all the way(15 miles).
Friday I called (again) and s/a told ne nothing found-car is perfect,no codes,no intermittent probs..will have QA man look at it Fri pm.
Sat am...waiting a report.
Adrian
 

·
Registered
2002 SLK 32 AMG, bone stock. 1987 190E 2.3-16 valve (destroyed). 2005 E320 new toy.
Joined
·
14,926 Posts
Please keep us updated, this is strange..........
 

·
Registered
SLK32 AMG
Joined
·
593 Posts
Discussion Starter · #13 ·
My wife spoke to SA today,tues,1 week into problem solving!
Seems they have managed to reproduce the fault,now they need to work out how to fix it....I dont know what it is as I was too busy to chat to him.Bet its intercooler related!!
A
 
1 - 13 of 13 Posts
Top