Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello,

Did a heater core... It really went well I must say....
(use the faq - on heater cores)
I am gonna try uncle benz's grease concepts. on the
blower motor... I will let you know how it goes......

Well, the instrument panel went out....
seems like it is the whole shibang... so
at night can't see speedo and cant adjust
the heat...... shifter is still lit... and I think
the power point it also........
First, I checked the fuses... can't find a bad one....
have trouble reading the box..... ANyone know
which one it is? (geographics)
And any suggestions? other than the fuse....
maybe it is a short.... any suggestions?
I am about to pop out the panel again....
really hate to have to do that.......

Monst
 

·
Registered
1989 190E 2.6 auto
Joined
·
250 Posts
^^^is that supposed to be Haiku? ;)

If you checked fuses and the dimmer setting, then possibly the rheostat (dimmer). I have read that is a component that can go bad. Otherwise, get out the wiring diagrams and multimeter and start having fun.
 

·
Registered
1984 190D 2.2
Joined
·
2,458 Posts
It could possibly be a loose or broken wire, but is most likely the rheostat. You have to take out the instrument cluster to get to this.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Yeah, they mysteriously went back on again.
Where is this dimmer setting, How do you make
them brighter or dimmer...
(how do you dim the instrument panel lights) ..........
and what does the reostat look like....
Does it sound like the symptoms of the reostat...
you know, sometimes they work sometimes they don't?
It probably is a dealer part, correct?
 

·
Registered
1984 190D 2.2
Joined
·
2,458 Posts
1 - 5 of 5 Posts
Top