Mercedes-Benz Forum banner

Instrument cluster flashing

23250 Views 44 Replies 21 Participants Last post by  shimshon
Does anybody know of a place or parts availability<br>for instrument cluster that flashes lights when any<br>combination of turn signals/wipers are used??? Mine<br>is doing this when I engage my wipers, all the idiot<br>lights flash intermittently and guages go to zero.
1 - 20 of 45 Posts

· Registered
Joined
·
36,559 Posts
Discussion Starter · #2 ·
Uh OH..... :(

What year is your W140?? The first W140s with traditional, rotating trip meter clusters have problem with the board itself. Your board is probably shorted out and needs to be replaced. Dealer will installed the new type of cluster used in 1995-1997 W140s with digital trip meter.<p>The cluster itself is about $1500 CDN...<p>Good luck...<p>Andy Kuo
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #3 ·
: Does anybody know of a place or parts availability<br>for instrument cluster that flashes lights when any<br>combination of turn signals/wipers are used??? Mine<br>is doing this when I engage my wipers, all the idiot<br>lights flash intermittently and guages go to zero.<p>So many of these happen now that the dealer has them available rebuilt. There is also a place in Florida called Programa that can rebuild yours. If you check your gas before pulling the cluster, you can drive without it in the car. Done it!<br>Push the cluster out by removing the black screen at the windshield post, then remove the two screws holding the vent duct in place and pull it out. Then pull more duct pieces out and reach in and PUSH the cluster out from behind. This is safer than trying to use hooks and pulling as they sometimes crack the lens. Good luck.
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
RE: Uh OH..... :(

i have the same problem, is there any recalls about it? it sound a lot more common problem than what i thought it was...

also, when you say "problem in the board", do you mean the printed circuit board behind the gauge cluster?
 

· Registered
Joined
·
218 Posts
short circuit problems is quite common with clusters even on new models. if you had the chance to investigate the board(printed circuit board) by yourself. it could be visible sometimes whats causing the short/open circuit. sometimes a busted resistor, one leg of a transistor cut, or some wires makes contact with the board thus causing it to short.
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
i am an electiral engeneer, so troubleshooting the board shouldnt be a problem to me, but how do you take the cluster off anyway?
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
Thanks for the great help...
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
this makes sense, and to be more accurate it can be the voltage regulation cap for the main power line in the entire cluster...
but do you know where this cap is located and value/voltage of replacement?
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
I ll try it tommorow, Thanks for the help...
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
just got it done, worked like a charm...
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
replaced the 470uF cap with 3300uF...it works just fine...
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
when you say "a bad cluster" do you mean its not working at all or just flashing when you turn the wipers/turn signals on?

if thats what it is, i would say try at the dealer first and see if they will honor the warranty since your benz is newer than mine, keep in mind there is a recall from Merc-Benz about this issue.
if the dealer is no help, then i would say its not a bad idea to try changing the cap...
 

· Registered
1992 400Se; 1984 230CE
Joined
·
78 Posts
I'm having this "flashing lights" problem too and am about to try the capacitor replacement solution. I've done some digging around and was interested to read that most electrolytic capacitors - of the type used on the instrument PCB are made with a stated working life. These vary from a standard 1000 hour life to the highest grade which have a 10000 hour life.

I'm not sure what spec capacitor MB originally used, but it seems likely that 10 yr old cars will most likely be operating with capacitors at the end of their reliable working life. I guess the actual failure date will vary signficantly depending on the component concerned, but it seems likely to happen sooner or later.

Anyone trying this repair may want to check with their supplier what "working life" rating the replacement capacitor has.

I'll let you know if my repair works !

Neil
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
I am a electrical engineer and never considered the life span of a cap in any of my studies or designs...

100000 hours of operation is more than 50 years of shelf life...the cap would outlast any other device in the car.

The fact is the cap in the cluster doesn't go bad, its just not large enough to maintain regulated voltage to power the cluster, when you start some devices such as wipers to headlights, the voltage fluctuates severely enough to cause this flash, since the voltage drops below the operating limits for the board, the flashing you see is nothing but the cluster turning off for fractions of second then starting back up.

Solution? bigger cap to store enough energy to overcome this voltage drop.

Again: the problem is not the cap going bad, its a design flaw.

Someone might ask here: if its a design flaw, how come the problem doesn't show up in all W140?

The answer is very simple: the voltage drop mentioned above is not severe enough to cause the problem unless your charging system is worn enough to the point where it doesn't maintain 14.4 charging voltage, and here I don't want anyone who had the problem before to panic, and go replace the alternator and batt! this charging voltage drop is normal due to the tear and wear on the battery, alternator and other electrical components in the car.
 

· Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,334 Posts
1 - 20 of 45 Posts
Top