Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1993 500E
Joined
·
142 Posts
Discussion Starter #1
I have a 1992 300SE (W140) that is having instrument issues with two things. The first is the oil pressure – it drops to zero on the gauge and triggers the red warning light. I have replaced the oil pressure sensor and still have the problem. The other problem is the battery warning light – this goes on and off intermittently.

My car has 126,000 miles. Should I have it repaired or can I get a digital cluster to replace it? If I can get a digital cluster, can I change the miles on the new cluster to the 126,000 miles I have on the car?

Thanks, Eric
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
The 92-94 dashes are a timebomb as someone put it, most of the time the entire cluser acts up when you use the washers or directional. Having said that my 92 never gave me any idication untill I had it repaired for the above issue. I re-installed it and most of the time it did not illuminate but after starting, it flashed came on and went away after a while. MB came out found nothing, I replaced the battery, then I decided it was a defective alternator, MB found nothing, I decided to replace the alternator since they indicated it could be intermittent, the light went away but came back a month later, then it mysteriously went away, six months later, it went one once.
The service advisor said to put duct tape over the bulb, I think when they rebuilt the cluser the power regulating transistor might not be the correct part, in looking over the MB service literature it seems the light is triggered by over and under voltage, I am not going to chase it.
The 95 or so digital cluster is a direct replacement, the later ones are not. A speedo shop can match your mileage, the dealer will want to put a sticker saying mileage unknown. Check S class eddie who posts here I think he has one close to your mileage
 
1 - 3 of 3 Posts
Top