Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hi there..im now an c36 owner its a blue metalic -95 with all opptions...gods gift to man!!!

I live in north of Sweden in the darkest of winter...its just about -30degrees outside

now to the question
have any of you install a blockheater in the engine on a c36....i wounder if its possible to buy the same heater for as to c280?? or do i have to buy a hoseheater for the radiator?

Sorry for my por englich!!
 

·
Registered
SL280
Joined
·
196 Posts
The MB engine block heater for the 280 will fit the 36 as the engines share the same block...

The MB engine block heater for the 280 will fit the 36 as the engines share the same block.

Where you are is cold, very cold, I would suggest a radiator heater as well, but I cannot see one as a listed MB part though.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
thank you! i vill order one tomorrow to install in the block..its no fun to do a coldst...

thank you! i vill order one tomorrow to install in the block..its no fun to do a coldstart at -35degrees..but i keep it in the garage at work till i got the varmer!
 

·
Registered
1998 C43 AMG
Joined
·
95 Posts
I believe a c280 block heater WILL work on your 36, but as a correction, the C36 engine bl...

I believe a c280 block heater WILL work on your 36, but as a correction, the C36 engine block was takin from an older 3.5L 6 cylinder diesel... That's why the 36 engine is a big hunk of solid steel.
Also, to take the 280, and bore it out to 3.6L, would make the cylinder walls incredibly thin, and create a weak link. Just my $.02.

I do think it will work though, and I too agree with the radiator heater. It doesn't hurt to be too safe on these cars[:D]!

Wyatt
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Mounting heater..took 9 hours/temperature problems now!!

Thanks for the help...i have installd the heater now..it took 9hours.. the frostplugg is mounted like a screw but needs to warm upp before removing...its pretty thight under the exhaust..

only problem now is that i think ive got air in the coolant system cause the temperaturmeter sink when i put on the gas..
any sugestion how to do, meiby the thermostat has broken?
 
1 - 5 of 5 Posts
Top