Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
1987 560SEL Astral Silver/Silver blue leather,Michelins,SONY
Joined
·
820 Posts
Discussion Starter #1
Been a terrible week to get at car stuff. I have not posted pictures before but am going to try. I have disconnected, pump in trunk, antenna motor, three plugs inside the "dome" light and fuses still blow when I try to put them in #15bay. These photos are what I see in the footwell on passenger side. I see the box MClare refers to marked Becker, but it appears to relate to the radio. There are, as you can see, two rather complicated looking connectors on it....look like a nightmare to disconnect them. Are these for the "alarm" you guys refer to? How n' hell do I get at lines into seat to unplug them, can't even get my hand under there.
Okay, I will try the photos now.
 

Attachments

·
Registered
1989 560SEL, 1979 Cressida MX32, 2006 F150 Lariat
Joined
·
1,510 Posts
This pic shows the carpet piece(Yellow circle) that needs to be pulled back from the seat to expose the seat control computer(Red circle) and it's connections. The seat will need to be all the way back and the front tilted up if you can do this.
 

Attachments

·
Registered
1987 560 SEL
Joined
·
47 Posts
Puddle light

Had a similar issue on my car. Fuse would blow, replace it and blow right away or wait a month. Thought it had to do with door locks. Replaced fuse with circuit breaker because I was getting tired of replacing fuses. I thought it had been a momentary overload. The circuit breaker would trip, cool down, reset, trip etc. I then knew it was a continuous problem. Before this the fuse had not blown for a month.
Finally figured out I had used the right rear door. Looked close at the door and discovered the puddle light (bottom of door to shine on puddles) had come out and the contacts were crushed. Sometimes the contacts would short to ground and cause the fuse to blow and reblow. The next time the door was used, the contacts would not short and the fuse would last a month. Put electrical tape over the hot wire and the problem went away. Then ordered a new puddle light. No strange electrical problems now.
 

·
Registered
1987 560SEL Astral Silver/Silver blue leather,Michelins,SONY
Joined
·
820 Posts
Discussion Starter #5
Okay, I will check the "puddle light". Bondavi, as you can see the Becker Box is held up with a plastic wrap. I will have to cut that I think to unplug anything. Is that going to cause problems. Looks like two really evil plugs go into that box....by evil I mean real ball busters to get out. When I get it unplugged I'll try a fuse again. Fortunately I have a whole bag of little white fuses so I can play this game for some time! Ha Ha!
Thanks fellas. I'll keep on going.
Will also play with the seat tomorrow too.
 

·
Premium Member
2012 CL550 4MATIC Coupe
Joined
·
9,992 Posts
Been a terrible week to get at car stuff. I have not posted pictures before but am going to try. I have disconnected, pump in trunk, antenna motor, three plugs inside the "dome" light and fuses still blow when I try to put them in #15bay. These photos are what I see in the footwell on passenger side. I see the box MClare refers to marked Becker, but it appears to relate to the radio. There are, as you can see, two rather complicated looking connectors on it....look like a nightmare to disconnect them. Are these for the "alarm" you guys refer to? How n' hell do I get at lines into seat to unplug them, can't even get my hand under there.
Okay, I will try the photos now.
Yes, that is the Alarm box. The way you disconnect it fairly easily is to take a little flat blade screwdriver (The pocket kind with the magnet on the end) and slide it under and gently pry up.

As for the seats, the connectors are under that front carpet flap. Slide the seat all the way back and raise the front up and take off that carpet piece. There are three large molex connectors, disconnect them.

Edit: Sorry, I posted this late. I typed it up this afternoon and got called afk, so posting it now.
 

·
Registered
1987 560SEL Astral Silver/Silver blue leather,Michelins,SONY
Joined
·
820 Posts
Discussion Starter #7
Okay men, here is the latest in the Fuse #15 saga. This morning we unlplugged the rear courtesy lights. We were able to get ONE of the plugs off the "Becker" box, but stalled out at trying for the larger one at the top of the box.
Fuse BAM when tried to insert it. So now we have air pumpt in rear, front dome light/seatbelt light complex totally unplugged, one plug out of Alarm box, rear courtesy lights off, antenna motor disconnected.
My car now looks like a Pick n' Pay junk heap. I MAY try to get at the seats although I don't recall the fuse code plaque says anything about seats. Or I may just try to put everything back together and wait for a visit to Dealership for a couple other little odds n' ends. At least I will be able to tell them what I think it is NOT. And truth is I do not NEED the antenna or the dome light complex either.....I can plug in my Iphone4s and set radio to AUX and get whatever I need for radio or music.
So there you have it Am inclined to concede that this stuff is more than I can deal with. LOL
But I HAVE learned a lot about the car. My worry now is how many little CLIPS have I ruined.
Thanks again.
 

·
Registered
1987 560SEL Astral Silver/Silver blue leather,Michelins,SONY
Joined
·
820 Posts
Discussion Starter #8
Oh. We keep discussin the Alarm Box........alarm for WHAT?
 

·
Registered
1987 560SEL Astral Silver/Silver blue leather,Michelins,SONY
Joined
·
820 Posts
Discussion Starter #10
Thank you. I think now the little chirp chirp, chirp chirp, chirp chirp I hear when shutting down and removing the key will be gone?
There are two plugs into that Becker box. Do I need to take BOTH of them off? One looks like a real bearcat to get off.
It would seem we (wife and I) have disconnected what we can to try to resolve the Fuse 15 thing but I will wait until tomorrow before I put everything back together. And I may NOT reconnect some of it......just put the carpet back etc. I'll lose my central locking of course but the other stuff I can live with. Besides, I've put so much into the car I have nothing left to buy silly little stuff to leave on the seats for thieves anyway! LOL
 

·
Premium Member
2012 CL550 4MATIC Coupe
Joined
·
9,992 Posts
Call me... PM sent.
 

·
Registered
1987 560SEL Astral Silver/Silver blue leather,Michelins,SONY
Joined
·
820 Posts
Discussion Starter #12
Okay folks, to complete this thread, here's the conclusion. I disconnected rear courtesy lights, trunk light,dome lights, antenna motor in trunk, air pump in trunk, passenger seat. Fuse 15 still blows instantly when you try to replace it. I have now buttoned everything back up and will have the troubles corrected by the Dealership guy. A man has to know his limitations. LOL. My dome lights still work,except the flashing seat belt light is always on. There is NO automatic antenna. Otherwise things work fine and I just made a 200 mile roumd-trip with AC going full bore. Mileage was 16.7 So I get along without the radio and I can put black tape over the #$$#%^ blinking seat belt light! Ha Ha!
BUT......thanks to all you merry souls and Mclare especially for your suggestions. I DID learn a lot about where things are and how they are connected. Now I just gotta get that air pump below spare tucked back into its corner properly. Don't laugh....it ain't as easy as you think!! LOL
 
1 - 12 of 12 Posts
Top