Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey all - well, i finally got round to changing my Timing chain on my '82 230CE.
While feedign the new one in, i managed to drop the chain and loose a tooth, so spent a happy few hours getting the valve timing back in the right spot :mad:

I also decided to replace the dizzy cap, arm, and leads, as the whole ignition system needed an overhaul :rolleyes:

I can get the engine to run, but it still feels "lumpy" and if i put her in Drive, the engine REALLY struggles to keep going.... which makes me think the ignition timing is still way off.

Does anyone know the ign timing specs for this engine ? The info sticker has been half torn off by the previous owner - which is making my life hell ATM, as i can't accurately check it ! I'm working on values for the 84 lumps, which is between 5 and 11 degrees, but i've got it in my head that the 82's were around 3deg.
 

·
Registered
-88 250D, -93 280TE-24 Sportline and -00 E270T CDI
Joined
·
898 Posts
There are TDC marks on Cam, front pulley and in distributor (remove plastic cover from under rotor) Are they aligned if you check?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
yeah, i checked those.
pulley is on TDC
Cam is aligned with the notch on the intake side of the block
Rotor is in line with the notch.
That's why i need the timing values for the ignition, so I can set it all up and see if it's something else.....
 
1 - 3 of 3 Posts
Top