Mercedes-Benz Forum banner
1 - 20 of 48 Posts

·
Registered
1989 300SE M103 250k miles
Joined
·
90 Posts
Discussion Starter · #1 ·
Diagram in the manual. From the plug that goes into the ezl there are four wires (next picture). The green one goes back to X11, and then there is a positive, negative, and brown ground. What I don't understand is that it shows the ground going to "inner wing front left (ignition coil)". What is that? And what is the wire coming from c that supposedly goes onto terminal 15? I don't know what it could be because there are no other wires except the ones coming from the EZL (except for a much larger ground wire that I think goes on one of the screw mounts (it's in the last photo)).

Bonus: does it look like I cleaned the ring terminals a little too hard? Is that a thing?

Book Font Handwriting Material property Pattern


Automotive tire Motor vehicle Bicycle tire Wood Finger

Hood Automotive tire Motor vehicle Car Vehicle
 

·
Registered
1989 300SE M103 250k miles
Joined
·
90 Posts
Discussion Starter · #7 ·

·
Registered
1989 300SE 240k miles
Joined
·
4,107 Posts
Mmhmm. Wow! You may be in a world of hodge-podge improper maintenance. My car, the PO did almost no maintenance the 3 years she owned it. But you can tell it was properly maintained prior to that.
 

·
Registered
1989 300SE 240k miles
Joined
·
4,107 Posts
FYI, I bought one of those $20 eBay ignition coils because I wasn’t sure if it was my problem. And I intended to replace it with a Bosch if it turned out to improve my engine. But I never got around to that replacement. I’m over a year now on that $20 coil. ..Though maybe I’ll clean that internal corrosion and put my old one back in when I take those pictures tomorrow.
 

·
Registered
1989 300SE M103 250k miles
Joined
·
90 Posts
Discussion Starter · #10 ·
Mmhmm. Wow! You may be in a world of hodge-podge improper maintenance. My car, the PO did almost no maintenance the 3 years she owned it. But you can tell it was properly maintained prior to that.
May be the case, the wrong coil plus the ICU being rebuilt by 4mercedes makes me suspicious. Just ordered a supposedly functional used Bosch ICU on ebay, might be nice to have it on hand for testing. MERCEDES 300E 300CE 300TE 300SEL 300SE IGNITION CONTROL MODULE 0035459232 107EM8 | eBay

I was like your previous owner up until recently haha, didn't do anything but oil changes for three years...
 

·
Registered
1989 W124 260E
Joined
·
6,598 Posts
The wires only go where the hole in the connector will allow it to go . Pins on coil are not the same size ..Also most have exrtra wires on there after factory ar aftermarket alarms are futted . good check fir the coil is -
Liquid Font Parallel Rectangle Glass bottle
 

·
Moderator
1987 & 1991 C126
Joined
·
6,254 Posts
"What I don't understand is that it shows the ground going to "inner wing front left (ignition coil)". What is that?"

That brown wire is the EZL ground and mounts to one of the two coil bracket fasteners. W3 in your diagram.

M
White Rectangle Font Organism Slope


Art Rectangle Font Brand Magenta
 

·
Outstanding Contributor
'17 GLS450, '14 GLK250 "Grandpa's Roadster" Project Car, 350SDL (Sold)
Joined
·
5,293 Posts
Brown is consistently ground on Mercedes. The wire that's missing is likely in a separate harness. I can't read your picture, or my copy of the circuit diagram, but it may be a red wire with a white marker. It's a pretty heavy wire; 1.5mm square, about 16 AWG.
 

·
Outstanding Contributor
'17 GLS450, '14 GLK250 "Grandpa's Roadster" Project Car, 350SDL (Sold)
Joined
·
5,293 Posts
Looked it up on another diagram. It's a pink wire with black marker and it's 14 AWG. The other two wires on that terminal are Red/White and Pink/Red, both 18 AWG.
 

·
Registered
1989 300SE 240k miles
Joined
·
4,107 Posts
Not much of value here, as they’re all black wires.
Motor vehicle Automotive tire Gas Auto part Metal

But, the two thickest ones come from the same wire loom. And they’re the only two in them.
Automotive tire Gas Wood Rim Metal

And there’s a brown wire what connects to the car with the big ground wire.
White Light Automotive tire Automotive wheel system Gas
 

·
Registered
1989 300SE M103 250k miles
Joined
·
90 Posts
Discussion Starter · #17 ·
Thank you everyone for your help! I ended up wiring it according to isthenew's photos. There are only two wires on each terminal, which was tripping me up because the diagram shows three on the larger one, but there are just no other wires in the area and it looks like isthenew's wiring is functional...

Even with wiring it properly I still get only cranking. My ignition coil is new with a yellow label but the old coil had a green label. Wondering if there's any reason besides ignorance that they would put the ignition coil for v8s on my six cylinder.

Going to do some tests to try and isolate the problem in a few days
 

·
Moderator
1987 & 1991 C126
Joined
·
6,254 Posts
Here's a wiring diagram for you.
Its the only one for your model in the MBCDs.

You can see the the coil as T1 on the left hand side.

As an aside, I just examined a coil I have here on the shelf downstairs and those connectors & wire ends are different diameters so they literally go on one way.. save the brown ground wire of course.... Looking at your & is the new's photos one can see this as well. Learn something every day!

Hey good luck!

Schematic Font Material property Parallel Engineering
 
1 - 20 of 48 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top