Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Registered
1991 300E 3.0L base
Joined
·
314 Posts
Discussion Starter · #1 ·
Needing a new instrument cluster, tired of the engine temp needle bouncing , mostly in the heat, settles but still acts weird after tapping on dash, (which sometimes activates cruise control accidentally)

If I go to the pick a part, what years are compatible for pulling the instrument cluster?

I'm going to just try unplugging the 12 prong connector and plugging it back in first, but if it keeps up its going to drive me nuts and I don't want an electrical short

Anyway to test the cluster or is it just basic

What's the ground fix that I keep reading about?


Font Gas Technology Engineering Machine
 

·
Registered
1992 CE 300-24
Joined
·
622 Posts
Did you check the sensor?
Usually that is the culprit.

What does the gauge do,
if you do a wiring check?

Does the needle move through
it range from bottom to top when
power is on, vs off, under test?
 

·
W163 and General M Gremlin
Joined
·
8,559 Posts
Needing a new instrument cluster, tired of the engine temp needle bouncing , mostly in the heat, settles but still acts weird after tapping on dash, (which sometimes activates cruise ....

Anyway to test the cluster or is it just basic

What's the ground fix that I keep reading about?
Community Search at the top of the page - exercise your fingers mind

And
ASR or Non-ASR cluster - there is a difference.
 

·
Registered
1991 300E 3.0L base
Joined
·
314 Posts
Discussion Starter · #4 ·
When it warms up to the right temperature it goes to 87 normal then it starts bouncing going way up (and only back to normal when tapped hard)


Non ASR

Does not look like this , there is NO triangle or system like that in mine

Speedometer Gauge Font Measuring instrument Screenshot
 

·
W163 and General M Gremlin
Joined
·
8,559 Posts
Just thinking aloud here:
Have you attempted to open it up and inspect the innards of that gauge?
If your tapping brings it back to normal, then it seems to indicate connectivity or sticky issue.
At the minimum, if it were mine, I would inspect and prep to use electrical contact cleaner.
Reassemble and test.
 
1 - 5 of 5 Posts
Top