Mercedes-Benz Forum banner

1 - 20 of 26 Posts
G

·
Discussion Starter #1
I just put the CL 19inch wheels on my 02 clk430cab with 8mm &12mm spacers (it rubs ((Help))

I'm so upset guys!! I waited so long for the wheels and spacers and finally i installed everything today!! And the front rubs with the 8mm spacer!! Not to mention the steering is all over the place.... when i'm driving the front makes a rubbing vibration... and The steering wheel is completly off!! The back with the 12mm spacer is fine with no problems!! Please can someone tell me why am i having these problems > do i have to go with a bigger spacer in the front? If i do it will stick out way to much i think? Please help!!!!!!!!!!!! Thanks<br> <br> Nick
 
G

·
Discussion Starter #2
Re: the tire size is 235 in front with an 8.5 inch rim & and 265 in the rear with a 9.5 in....
 
G

·
Discussion Starter #3
Are the wheels balanced ? Where'd you get the spacers ?

Unbalanced wheels will shake. Where does it rub ? Inside or on the fender ?
 
G

·
Discussion Starter #5
Re: i got the wheels from (more inside)

i got the wheels from luke at tire rack so i'm shure they are balanced!! the spacer are from fred at wheeladapter. it rubs in the inside not the fender the iner part of the rim by the suspention!! Thanks
 
G

·
Discussion Starter #6
Nick....it rub because the offset is still wrong even with 8 mm. Here's what you should.............

<br> do. Why don't you switch the rear 12 mm spacer to the front just for testing to see if it still rub and make that you also used the rear longer nut bolt too. If it still rub then you might need thicker spacer or change the tires in the front from 235 to 225-35 series. If you do this, you will find match combination.
 
G

·
Discussion Starter #7
Then the spacers might not be flat or of equal size..

that's why the steering wheel is off.<br> <br> Did you measure the spacers ? Was it exactly 8mm ? The 8.5 wheel has a stock offset of +44. The 8mm spacer brings it down to +36 which should be good. Is your car lowered ? Maybe your camber is off. Have your wheel aligned. <br> <br> Mine never rubbed in the past.
 
G

·
Discussion Starter #8
Re: I just put the CL 19inch wheels on my 02 clk430cab with 8mm &12mm spacers (it rubs ((Help))
 
G

·
Discussion Starter #10
you need at least a 12-15mm spacer on the front for that to fit or else it may run on the inside
 
G

·
Discussion Starter #11
Hey Peter :)...I think 12 would be too much for the front..

I used a 10mm before and the clearance between fender and tire was about 1 mm so I switched to an 8mm spacer and the fit was perfect.<br> <br> I had the same wheels with the same tire specs on.
 
G

·
Discussion Starter #14
Guys what if i got An alignment > Would that help, because it rubs right by the>>>

inside by the suspention black piece that hangs over the tire with the bolt at the end!! Thats whats rubbing on the inside of the tire!! but the alignment is way off too!! guys thanks for the help!!!
 
G

·
Discussion Starter #15
If its rubbing on the suspension components, You need to either use thicker spaces or thinner tires
 
G

·
Discussion Starter #19
Yes do a full wheel alignment first...

Worst case, get a 10 mm H&R spacer. They're not that expensive.<br> <br> Mine was lowered with H&R springs. Two other guys had the same setup too so I can't see why yours would have problems.<br> <br> Our specs were the same as yours :<br> 8mm spacer 19x8.5 front with 235/35/19.<br> <br> I'm guessing bad camber/alignment.
 
1 - 20 of 26 Posts
Top