Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
6,457 Posts
Discussion Starter #1 (Edited)
I drove my 05 500 to work today - 45 minutes away from home. All went well, cruising at near 20mpg, computer display, and I was actually enjoying the annoying rumble of my Dunlop SP Sport 5000. Coming back on a single lane road I flicked up the headlights and bammm!!! in a flash, the speedometer needle dropped to zero like a rock, and every brake related safety light came on - BAS, ETS, parking brake, low disc, brake service light, name it, it was lit!!!! I'm 45 minutes away from local dealer, so I call them and they ask to carefully bring the truck in. On the way, I discover that I'd lost touch shift also - only D would show in the display. The tachometer was dead also!!!! What the heck was going on? I hit the main highway usually packed with cops and I was driving at some unknown slow speed, thinking of all kinds of excuses if I ever got stopped - for, maybe driving too slow on a major highway. I know 55mph usually comes at 2000RPM (the tach was working, thank God), so I tried cruise control - dead also!!!! Oh, boy!!!! Then I notice the trip computer was trickling down my mileage it was falling 1/10gpm about every 30 seconds - yes, I timed it!!! By the time I got to the shop, it was reading 10.1mpg and the truck was somewhat sluggish.

Anyone ever had this happen to them??? A few hours later my SA calls me, ... bad traction system control module. Will be replaced tomorrow while I cruise in a 07 E350. I still have 9K/1yr to warranty expiration and I'm now seriously considering xtended warranty.
 

·
Registered
Joined
·
4,714 Posts
Darkmann,

I am really sorry to hear about your problem - Thank God you still have the original warranty and the option to purchase an extended warranty.

I love these trucks but they really do test your patience!

My ML is fine at the moment but covered by no such warranties and in Africa (where parts and expertise are in short supply) - I dread to even think of the cost of repairing and/or replacing a part such as the one you describe above.

It does beg the question though; what one does once the original warranty ends - Then the love affair between man and this machine is really tested!

Best of luck with the repairs!
 

·
Registered
Joined
·
2,126 Posts
I would definitely consider a warranty. Chances are that it will pay for itself several times over (at the dealership). I have ~4k left on my extended warranty and then I'm on my own. I still have issues that pop up now and then and that scares me. I'm going to look for a good indie for post warranty needs.
 

·
Registered
Joined
·
4,714 Posts
I would definitely consider a warranty. Chances are that it will pay for itself several times over (at the dealership).
All true words spoken sir but one fundamental problem here in my tiny West African state; no such thing as a warranty - original, extended or otherwise! (LOL)

I'm going to look for a good indie for post warranty needs.
That's the one saving grace - Loads of independent mechanics over here and CHEAP too!

Only problem is that one may have cheap labour but woeful access to parts - even common use items like brake pads, rotors etc.
I have to order from US - My problem is compounded by the fact that I have an ML55 (the only one in the country) and most parts stores stock for the more common, ML320.
 

·
Registered
Joined
·
2,982 Posts
Tick, tick, tick... My extended warranty just ran out last month. I never really used it other than that cluster issue I had a few months ago. (But I don't regret having it either.) Let's hope she doesn't decide that now is the time to fall apart.
 

·
Registered
Joined
·
2,126 Posts
Unfortunately, I've used the hell out of my warranty. I will take the ML in for my final work next week. I drove to Maine this weekend to go skiing and the morning after getting back, the ML went into the dreaded limp mode. When I restarted it, it was fine, but that cannot be good and I don't want this problem on my dime.
 

·
Registered
Joined
·
190 Posts
I drove my 05 500 to work today - 45 minutes away from home. All went well, cruising at near 20mpg, computer display, and I was actually enjoying the annoying rumble of my Dunlop SP Sport 5000. Coming back on a single lane road I flicked up the headlights and bammm!!! in a flash, the speedometer needle dropped to zero like a rock, and every brake related safety light came on - BAS, ETS, parking brake, low disc, brake service light, name it, it was lit!!!! I'm 45 minutes away from local dealer, so I call them and they ask to carefully bring the truck in. On the way, I discover that I'd lost touch shift also - only D would show in the display. The tachometer was dead also!!!! What the heck was going on? I hit the main highway usually packed with cops and I was driving at some unknown slow speed, thinking of all kinds of excuses if I ever got stopped - for, maybe driving too slow on a major highway. I know 55mph usually comes at 2000RPM (the tach was working, thank God), so I tried cruise control - dead also!!!! Oh, boy!!!! Then I notice the trip computer was trickling down my mileage it was falling 1/10gpm about every 30 seconds - yes, I timed it!!! By the time I got to the shop, it was reading 10.1mpg and the truck was somewhat sluggish.

Anyone ever had this happen to them??? A few hours later my SA calls me, ... bad traction system control module. Will be replaced tomorrow while I cruise in a 07 E350. I still have 9K/1yr to warranty expiration and I'm now seriously considering xtended warranty.
Wow all that Hell and it turns out to be a Traction Control Module? Unreal! Glad that was the ticket for ya Dark. I'm contemplating extended warranty myself, only because I had a 1990 300ZX that gave me some interesting grief with a head gasket. The ext-warranty saved me there.
 

·
Premium Member
Joined
·
6,457 Posts
Discussion Starter #8
Wow all that Hell and it turns out to be a Traction Control Module? Unreal! Glad that was the ticket for ya Dark. I'm contemplating extended warranty myself, only because I had a 1990 300ZX that gave me some interesting grief with a head gasket. The ext-warranty saved me there.
Other than the interesting grief, how do you like the Z32? Was it a TT? I picked up a 96TT in December. The thing had only 39K on it. It drives like a dream.
 

·
Registered
Joined
·
190 Posts
Other than the interesting grief, how do you like the Z32? Was it a TT? I picked up a 96TT in December. The thing had only 39K on it. It drives like a dream.
Hey Dark,

Z32 is still my favorite body style inside and out, well next to the S30 of course. And the butterflied split intake plenums are far more intimidating looking than the ML's. Sadly it was a Non-Turbo, 2+2 with an auto. But heck, 222 horsepower stock at that time was phenomenal and made the car incredibly fun to drive. I miss it. I would own one again in a heartbeat. I wouldnt balk at a Z33 either. But they are harsh to drive.
 

·
Registered
Joined
·
4,714 Posts
...A few hours later my SA calls me, ... bad traction system control module. Will be replaced tomorrow...
I think he (or rather his SA) said it was his traction control module?
 

·
Registered
Joined
·
559 Posts
Darkmann, had the same thing happen to my ML before I sold it. But mine didn't go into limp home mode. At first it came up as the rear wheel speed sensor. Had that replaced and the lights were still on. They reset it and cleaned the rear wires as there was a bulletin out on possible chafing or corrosion of the harness in that area. I drove two feet from the dealer and the lights came back on again...turned out to be the 4ETS module too, which I have sitting in my garage now. $1300, ugh. Happened about 5 months out of the extended warranty.

And then of course 3 weeks later a drunk driver sideswipes my ML while it's parallel parked at the side of the road! Not horrible damage, but he happens to hit the wheel that was just fixed, grrr....if it happened before I took it to the dealer I wouldn't have been out that money! And it was at this point that I knew that the ML had to go due to bad luck.

So nonetheless I sold it to my buddy and his wife with full disclosure. Guess what? Nary a problem in the last 16 months except for having to change the spark plugs and wires! :p
 
1 - 14 of 14 Posts
Top