Mercedes-Benz Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I just purchased a 2002 silver c32 with 100k on it. It started shifting from 1st to 2nd super hard (when its cold it does it worse) i called the dealer I purchased it from and they told me they had the conductor plate in the trans replaced and that should have fixed the problem. So I took it back to the people that did the conductor plate and said fix it again. They told me it was the TCU for the trans (but the car never threw a code) and they wanted 1k to fix. I called mercedes benz and they told me $600 to r and r the TCU. I ended up taking it to another shop that does tons of benz and bmw work and he pulled the pan and said the fluid was burned and saw shavings. I did buy a aftermarket warranty and they are telling me that they found a trans with 70k and they want to put that in the car and the shop found one with 30k miles on it but the warranty company said if I put the shops 30k trans in they wouldn't cover it if it goes out (I have 1.5yrs left on the warranty) seems strange, but I am also worried that the TCU is bad as well? I would hate to see the trans go in and still have the problem. Do you think it could be a TCU also? and has anyone heard of trans problems with these C32's. Also is the C32 and the C320 have the same transmission. I think this aftermarket warranty company is trying to screw me?
What can I do to upgrade my power without spending a ton of cash. I did put k&n filters in and H&R springs and Rims off a newer E3 series. DIY's
 
1 - 1 of 1 Posts
Top