Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1983 300d
Joined
·
4 Posts
Discussion Starter #1
I went to check out an 83' 300d last Monday, that I had found on craigslist for $1,000. I went back on friday and picked it up for $650 :D. I've driven it over 200 miles since I bought it and the only unexpected problem I've had is a dead battery.
It does have mushy brakes that require a lot of effort(PO says it needs a new master cylinder) and theres a loud whine under acceleration and deacceleration coming from the back when its cold. (PO said it needs a new drive shaft carrier)
Other than that its great! Any thoughts on the brakes and noise?
-Pierce
 

·
Registered
1981 240D
Joined
·
185 Posts
Congratulations on your new car! You should post some pics for us to see. I would get a second opinion on the master cylinder. It might be fine. You should also check the brake hoses. If they are old, they will not be rigid enough and will cause your brakes to be somewhat 'mushy'. You may have MS issues as well. It couldn't hurt to check the hoses, replace your brake fluid and bleed the lines. I am not sure the drive shaft carrier noise would be temperature dependant. Since I have never had this problem, I can't immediately identify it (of course I also haven't heard it). It might be your brakes dragging. I am sure one of the other members will chime in with better info on the noise.
 

·
Registered
85 300D, 84 300D, 05 Mustang GT Vert, 11 VW JSW TDI, 95 Del Sol, 88 IROC, 95 Villager, 04 Wrangler
Joined
·
602 Posts
If you put your location in your profile, someone close may be able to swing by and help.
 
1 - 4 of 4 Posts
Top