Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Premium Member
1996 SL 600
Joined
·
15 Posts
Discussion Starter #1
1996 SL 600. Anybody have information on how to troubleshoot the hydraulic suspension control unit?
I cannot locate a fuse or relay that controls this, which is where I would like to start. The hydraulic reservoir is full, no leaks observed. Hate to have it towed in without some idea of what’s happening.
 

·
Premium Member
1996 SL 600
Joined
·
15 Posts
Discussion Starter #3
See ADS component locations and test procedures here: https://manual.startekinfo.com/manual/JSP/cd1/content.jsp

R129 Adaptive Damping System (ADS) was updated in 1996, so we do not know whether you have ADS 1 or ADS 2.
Reduce guessing and start by reading your diagnostic trouble codes (DTCs).

Good luck!
Thanks for helping. I have determined that indeed I have the ADS2 since date of manufacture was 01/96.
The link is very informative.Have tried to read the DTC's. Several years ago I bought a forum member's CarSoft 7.4 with all the cables, etc. including an old laptop running Windows 98 which is needed to run that version of CarSoft.. I cannot get it to work correctly. It does connect and I got a few error codes but nothing related to the ADS. Mostly I get messages that the ""module is not present. Testing with analog which should read for ADS reveals nothing and after a week of fighting I am ready to buy something better. Any suggestions? A HHT- handheld tester-is referenced in the link.
would be interested in other members experiences with the diagnostic hardware software out there!
 
1 - 3 of 3 Posts
Top