Mercedes-Benz Forum banner
1 - 14 of 14 Posts

·
Registered
2002 C240
Joined
·
149 Posts
FAULTY RADIATOR COOLER TANKS
Causes tranmission failure

According to Mercedes Benz Star Bulletin #P-B 27.55/50f, dated March 24, 2006, there is a problem with Valeo radiators up to production date 9/2003 installed in models:

203.040/061/064/065/081/084/261/264/281/284/740/747/746 also

I have a 2002 C240 and replaced mine as a precaution
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
22,933 Posts
If you have a Valeo radiator in one of those models/years, replace it. Period. The Valeo will have that name on it somewhere - either on plastic or on a lable. The MBZ dealer replacement will be a Behr. Standing at the front of the vehicle with the hood raised, look at the right side of the radiator, about halfway down. If you find a label that is clearly marked with the Behr name or (B) logo, then it's fine. You may need to use a mirror to read the label. Also, look here:

Mercedes-Benz Owners' Forums - View Single Post - Identification of the early Valeo Radiator?
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #4 · (Edited)
i cant find any label or marking on the radiator except one on the side down below, and i used a mirror rudeny said and it only has numbers and letters i didnt see anything with a B. I saw the link posted by rodeny and it seems my end match the ends of the Valeo radiator (The metal holding the radiator in place)... what are symptoms of the coolant leaking into the tranny... or symtoms in general? - thanks jster
 

·
Registered
'07 C280 4matic, '06 530i, '98 ML320
Joined
·
1,562 Posts
when the car is cool (engine temp), open the coolant reservoir. If you see a thin layer of shiny liquid... you know you are in trouble.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
22,933 Posts
Not every Valeo radiator is defective, but given the possibility of a $250 part ruining a $6K transmission, well, I'd replace the $250 part. It's not an easy DIY because of all the connections and fluids you have to deal with, but it's worth it to save your transmission.
 

·
Registered
'07 C280 4matic, '06 530i, '98 ML320
Joined
·
1,562 Posts
Not every Valeo radiator is defective, but given the possibility of a $250 part ruining a $6K transmission, well, I'd replace the $250 part. It's not an easy DIY because of all the connections and fluids you have to deal with, but it's worth it to save your transmission.
+1.
 

·
Registered
Joined
·
30 Posts
The easiest way to tell the Valeo radiator from the BEHR radiator is to look at the top right corner (when youre standing facing the car with the hood open). If you see a little protrusion (welding seal), you have a BEHR. If you dont, you have a valeo. See the red circle in the attached pic of the BEHR
 

Attachments

·
Registered
W203 C240 Classic
Joined
·
2 Posts
if you have valeo radiator in the car get it changed and get your transmission fluid checked that is not contaminated with coolant. i learned the hard way. new transmission costed me $4500 canadian after the mercedes coverd 50% of the original price.
 

·
Registered
Joined
·
15 Posts
All Valeo radiators bad?

I'm looking at buying a 2004 C240 wagon with a build date of 12/2003 and it has a Valeo rad. I checked the coolant and it looked clean.

Based on a previous post the defective rads were built up to 9/2003. I'm confused as to whether Valeo fixed the problem with subsequent rads, or if they went with Behr rads after that.

Thanks.
 

·
Registered
2004 C230 Kompressor Sedan; 1975 Triumph TR6
Joined
·
81 Posts
I have a Valeo rad and my car is built in 08 / 2003 should I am assume that I am not affected because my car is a 6sp as opposed to Auto as I doubt that there is an oil cooler for manual?
 

·
Registered
Joined
·
1 Posts
Hi mb peoples new here anyway ive got a clk270 with the veleo radiator no problems yet can anyone tell me can i put some additive into rad water ie rad weld or somthink to make sure i dont get any probs at a later date cheers thanks for your time dudes :)
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
22,933 Posts
I don't believe any additives will help. The problem is a rubber seal that fails. I would o ahead and spend my money replacing it.
 
1 - 14 of 14 Posts
Top