Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
01 C240 Sport
Joined
·
12 Posts
Discussion Starter #1
Hi,
My battery/alternator alert came on and the manual says that the Poly-V may need to be replaced. It said not to drive the car, although I have driven about 2 miles around the neighborhood before I realized its not a "its time to replace the battery" message. Now I'm really strapped for cash and am scared to find out how much this will cost although I now know its necessary to fix the problem immediately. Can I do it at a standard mechanic shop, or does only the dealer have access to the right parts? Can anyone give me an estimate of how much this could cost with labor? And how many miles could I go (local mechanic is 1 mile away, dealer is about 10.
Thanks.
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
if your belt was the problem or came off, you would have lost power steering, the car would have overheated and the alt light come on. first check and see if the belt is still in place. if it is, its not the problem.
 

·
Registered
C230K Sport Sedan
Joined
·
5,368 Posts
You only have one belt, it shouldn't cost more than about $35 for a Contitech, maybe less, check Pep Boys or Autozone for an American brand. You can do it yourself, not a big job or pay an independant $40-50 to put it in. That needs to be replaced about every 50K miles. You may need a tensioner if that's what's causing the problem, that's more expense, maybe $100 plus another $40-50 to replace it over the belt replacement costs.

Haha, haven't heard poly-v belt terminology since I used to restore classic cars.
 

·
Registered
2002 C230 Sport Coup and 2006 ML350
Joined
·
1,127 Posts
if your belt was the problem or came off, you would have lost power steering, the car would have overheated and the alt light come on. first check and see if the belt is still in place. if it is, its not the problem.
Geez, agreed!
Open the hood and look before you post.
You might need an alternator
 

·
Registered
01 C240 Sport
Joined
·
12 Posts
Discussion Starter #5
ah thanks for the replies. I noticed that it only comes on when I stall the car (just bought it and learning manual) and not during normal driving, so I'm assuming its just getting a misreading when the engine is in process of stalling.
 
1 - 5 of 5 Posts
Top