Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
2000 S430
Joined
·
26 Posts
Discussion Starter #1
I am trying to determine if my Transmission Control Module is bad. Anyone know what the voltages across various pins on the TCM are? I did a search and I found a thread that discusses this very subject but for the W163 M-class:

http://www.benzworld.org/forums/attachments/w163-m-class/212971d1230685098-code-p0748-ect01.pdf

Is the W163 M-class ECT pin layout the same as the W220 S-class TCM?

The W163 ECT wiring diagram given by the above link matches the TCM and the harness connector for the W22O.

My voltage readings are: pin 30/29 12v, pin 30/1 10.77v, pin 30/38 0v.

The 0 volts between pins 30 and 38 point to a bad TCM card.

Anyone have any opinions?

Background: P0715 code. Replaced conductor, connector, o-rings, tranny fluid, filter, gasket, magnet. Car remains in limp mode.

If anyone has a TCM they would like to sell cheap (A026 545 71 32 OR A022 545 51 32) - please PM me. Thanks.
 

·
Registered
03 E320 4M Wagon & 97 E320
Joined
·
3,926 Posts
There is a very good chance that all you need to do is to have the codes in your ETC (TCM) cleared. When you get P0715, there are some codes in the ETC.

When there are codes in the ETC, the solenoids are shut off of power. The ETC is measured to be "bad".

You do need to find someone who has equipment to be able to talk to the ETC. A generic OBD II scanner cannot.
 

·
Registered
Joined
·
5 Posts
Can anyone else elaborate on w220 TCM testing please?
I scanned my 2002 S430 with Autel MaxiDas and get codes for solenoid, however, I suspect it to be the TCM from other factors. Someone please help me out as I have already replaced the Transmission Conductor Plate,13 pin connector with O-ring,filter,gasket and had the transmission fluid flushed and filled with new fluid and I used ALL FACTORY PARTS FROM MERCEDES-BENZ. And the thought of going back into the transmission valve body is not an option I want to exercise unless it is absolutely necessary.
 

·
W220 Moderator
Joined
·
6,028 Posts
I've never had a TCU that gives Solenoid Codes when it's dead ............... Speed Sensor Codes yes, even after Conductor Plate Renewal, cure was a new TCU.

As said SDS or a dearer machine is the only way to certainly sort it out.

HTH,
 
1 - 4 of 4 Posts
Top