Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Green '02 E320 Wagon
Joined
·
570 Posts
Discussion Starter #1
Hello, the climate control in my 2002 E320 4matic wagon must be having a problem. How can I get the temperature sensor codes (and DTC codes and other codes?) which people mention on posts here?

The climate control constantly blows strong, either full hot or full cold. The fan rarely blows moderately or slowly. I leave it set at 72 degrees F with driver and passenger on Auto (and, subsequently, the fan is on auto). I often drive with two windows cracked for fresh air, but this problem persists even with all windows closed.

Now that the weather is hotter, the A/C is kicking on, blowing full cold for my entire 45 minute commute, freezing my hands and arms. Yesterday, I noticed the dashboard temp sensor said 91 degrees F which I hardly believe. But that doesn't influence the cabin fans, does it?

Thanks for your help.
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
See the parallel thread, "AC Quits Blowing Cold Air" for links to places with the information. Current-sensor mode is easy; simply hold the REST button for more than five seconds. Getting codes is a bit more complicated, but well covered in the other thread.

What's not mentioned in that thread (or I missed it if it was) is the check for the interior temperature sensor fan. The little grille in the overhead lamp compartment, left side, is the inlet. With the car on, place a 1cm x 1cm piece of paper against that grille, and the fan should hold it in place.

Your symptoms sound like the car doesn't know how cold or hot it is inside.
 
1 - 3 of 3 Posts
Top