Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
2000 s430
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi.I have a 1999 sl500.I have been working on a module to operate my top remotely.I would like to know how to make the top module stay "hot' all the time.I have found a switched 12 volt wire at the module.I removed #19 and #20(soft top and roll bar) fuses under the hood and powered them seperately so that I would'nt back feed the ignition switch.The windows will operate via the console switches as normal.The top will not move in either direction.The button blinks when in the up position.The top will work as normal if I turn the key switch to the on position.Obviously there is another circuit I am missing.Any thoughts would be appreciated.Thanks
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,560 Posts
I don't remember exactly but I think someone in England or somewhere did something similar.
I think he got it working.
Not in my car though.
You are defeating a lot of safety e sews.
Regards.
aam.
 

·
Registered
2000 s430
Joined
·
7 Posts
Discussion Starter · #3 ·
I don't like to change anything about my car at all,even aftermarket wheels.But I do like the remote top.If the remote would work with the ignition in the on position ,it would make things a whole lot easier.I was wondering,how did Pigzmickey make his top work with the ignition off? Thank
 

·
Administrator
1998 Pano SL500; 1993 SL500; 2005 ML270cdi
Joined
·
9,056 Posts
I think we had a topic a while back with a company producing a one touch soft top controller which could possibly be activated by a remote control.
 

·
Registered
07 SL350, 14 BMW320, 05 SLK and 4.6 MGBV8
Joined
·
745 Posts
There is already a module you can buy that allows keyless operation.
Ebay is, or used to be, littered with them. I do not see the point of it though. But again, over here we do not exactly use the top function every day...

The module completely rewires the soft top as the factory operation is reliant on several switch factors - the ignition and transmission in Park being the two main ones. If you are making your own module, simply provide it with a separate feed from the fuse box 'hot' side.
 

·
Outstanding Contributor
2003 SL500, 2003 SL55, 1998 SL500, (2) 1991 300SLs
Joined
·
4,559 Posts
I was wondering,how did Pigzmickey make his top work with the ignition off? Thank
The Mercedes top controller needs power on its pin #1.2 to operate, and with the stock wiring this only happens with the ignition key ON. So to make this work the module that 'Mickey installed has a relay that shorts pin #1.2 to pin #1.1 (#1.1 has constant +12VDC). This relay is energized by the automatic top control module during an opening or closing operation.

In my opinion 'Mickey's uses the relay because it is a commercial product and it simplifies installation. A better way would be to move the feed to pin #1.2 from it's existing fuse within the fuse box to a fuse that supplies +12VDC with the key OFF. This would require a bit of effort but would eliminate the relay.
 

·
Registered
2000 s430
Joined
·
7 Posts
Discussion Starter · #8 ·
hi,thanks everyone for your suggestions.Bob,this was the first thing I tried last week.I bought a 24 hr subscription to Startek to look at the module .when I jumped 1.1 to 1.2,the power back fed to the ignition.When the ignition is on,the remote control is cut off.I even powered 1.2 by itself .the windows will operate by way of the switches.not the soft top
 

·
Outstanding Contributor
2003 SL500, 2003 SL55, 1998 SL500, (2) 1991 300SLs
Joined
·
4,559 Posts
So, with your module connected and a separate feed to #1.2 the top works via the control switch? If yes, then I suggest you try the relay. Your module should normally leave the relay de-energized and energize it only during a top opening/closing operation.
 

·
Registered
2000 s430
Joined
·
7 Posts
Discussion Starter · #10 ·
Bob,I can make a relay energize on the third push of the open/close button on the remote.But after the top starts to close/open,I will have no control with the remote until the cycle ends and the ignition cuts off.I have my module set up to press any button to stop the cycle.
 

·
Outstanding Contributor
2003 SL500, 2003 SL55, 1998 SL500, (2) 1991 300SLs
Joined
·
4,559 Posts
For further discussion I'll clarify that the module that 'Mickey installed in his car and was offering for sale was manufactured by a German company named Reinhold Engineering.

The Reinhold module works the same as your design in that pressing any button on the remote will kill the top during an automatic cycle. This implies that the Mercedes remote module issues signals with the key on.

You mention that your remote does not work with the key on...Have you verified that there are no output signals from the remote module when the key is on, or have you simply noticed that the locking system does not respond to the remote with the key on?
 

·
Registered
2000 s430
Joined
·
7 Posts
Discussion Starter · #12 ·
Bob,I have getting my signals from the vacuum pump in the rear.both outputs(13 & 14)remain high.I am not sure where the remote module is.thanks
 
1 - 12 of 12 Posts
Top