Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Can't get the hood to shut. Sometimes it latches down, then while driving it'll pop back open. Did my hood release cable just break or is it a simple lube job. The actual latches look fine and I don't think they need adjustment. So leads me to believe it might be the cable.

Anyone have any pointers?
 

·
Registered
Joined
·
865 Posts
Can't get the hood to shut. Sometimes it latches down, then while driving it'll pop back open. Did my hood release cable just break or is it a simple lube job. The actual latches look fine and I don't think they need adjustment. So leads me to believe it might be the cable.

Anyone have any pointers?
Clean and lube the latches. There are 2....one on each side of the radiator support. Sometimes the loops on the hood need to shimmed. MB sells shims for this purpose. I had to do my passenger side.
 

·
Registered
Joined
·
128 Posts
Can't get the hood to shut. Sometimes it latches down, then while driving it'll pop back open. Did my hood release cable just break or is it a simple lube job. The actual latches look fine and I don't think they need adjustment. So leads me to believe it might be the cable.

Anyone have any pointers?
In my case it was the interior lever. It has spring inside that becomes weak.
 

·
Registered
Joined
·
23 Posts
Like another post, I have the same problem and find that if I push the lever forward after pulling it aft to open the hood, the hood locks normally when dropped and stays down.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
4 Participants
Mikei
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top