Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1990 560SEL, 1999 SLK, 2005 BMW 525I
Joined
·
208 Posts
Discussion Starter #1
I am still learning about my '96 SL320, which I have owned for about 3 weeks. i am enjoying it driving it and taking care of some minor issues. This forum has been extremely helpful. NEW ONE. At idle I hear a high pitch whistling sound emanating from the engine. Is it normal? Drivieability does not seem to be affected in anyway, I like the performance of the 320 engine. Thanks
 

·
Registered
MB SL600, MB 380SE, Suzuki Grand Vitara, 38' Chris-Craft, Volvo V70XC, and my own two feet...
Joined
·
4,131 Posts
Do you mainly hear it after startup?

Does it go away after a few minutes of running?

If so, it's probably just your auxiliary air pump for the emissions system, and it's normal. As those pumps age, they get real noisy. FWIW, mine does the same thing...sounds awful, but since it's not an important part, I'm guna get my use out of it before I buy another one for $600. I'd just lose it entirely, except I'm afraid the car would throw codes on startup.
 

·
Registered
1990 560SEL, 1999 SLK, 2005 BMW 525I
Joined
·
208 Posts
Discussion Starter #3
This sound appears to be present at all times, actually I noticed more are running the car for awhile. It almost sounds like a vacuum leak, however, as I mentioned the engine is operating fine, so it seems.
 

·
Registered
00 SL500 SOLD, 05 SL600 Sport, 09 Silverado 4x4 LTZ,SOLD '15Silverado LTZ 6.2 8Speed John Deere 318
Joined
·
1,781 Posts
The noise that you have described could be a VACUME leak, You should have it looked at before to much time goes by. It could be a simple loose or cracked hose.
 

·
Premium Member
95 SL500, K&N, NEOKEN Ported TB, Custom Intake, RENNtech Sport Exhaust, AMG I Monoblocks
Joined
·
10,980 Posts
Hi Sunny,

What I would do is try to listen and look very closely and see where excactly the whistling sound is coming from. From what you describe, it does not seem like its inside the motor, but it is under the hood. More than likely you should be able to track it down.

I agree with drags1998, could be a vacume leak from somewhere. You just have to listen and look very carefully. This should at least give you somewhere to start. Good Luck!
 

·
Registered
00 SL500 SOLD, 05 SL600 Sport, 09 Silverado 4x4 LTZ,SOLD '15Silverado LTZ 6.2 8Speed John Deere 318
Joined
·
1,781 Posts
WARNING !!!!!!!!!!!!!!!!

WARNING<WARNING,Be VERY CAREFULL messing around under the hood with the ENGINE RUNNING!!!!!!!! Sorry for such an alarming post, But I have seen someone nearly KILLED when LOOSE CLOTHING got caught in the Acc. Drive system!!!!!!!!!!!!! If you have little or no time under a hood then PLEASE leave it to a PRO!!!!!!!!!!!
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,391 Posts
WARNING<WARNING,Be VERY CAREFULL messing around under the hood with the ENGINE RUNNING!!!!!!!! Sorry for such an alarming post, But I have seen someone nearly KILLED when LOOSE CLOTHING got caught in the Acc. Drive system!!!!!!!!!!!!! If you have little or no time under a hood then PLEASE leave it to a PRO!!!!!!!!!!!

+1 Long hair I have seen somebody lose a part of his scalp.
Ouch.
aam.
PS.
No watches or rings etc.
 
1 - 7 of 7 Posts
Top