Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello. I have a 1992mod 230E with an idle problem that doesnt happen all the time. The idle goes up to around 2500-3500rpm. It can happen when the engine is warm and the car has been running in park for a while and the temperature gets higher, or after high load. If i stop the car and wait for a while before starting it again its back to normal. So the problem doesnt always occur. The car also stalls when cold if i dont press the gas a bit, but too much and it stalls. Thanks in advance and hope someone can help!
 

·
Registered
'94 E220
Joined
·
1,207 Posts
Taking a video for this symptom can help us understand the situation.

I would check:
The throttle butterfly and make sure its not sticking and its clean, also the black plastic under intake butterfly unit tends to get cracked.

Make sure that the gas pedal is not sticking too.

Sent from my POCOPHONE F1 using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Taking a video for this symptom can help us understand the situation.

I would check:
The throttle butterfly and make sure its not sticking and its clean, also the black plastic under intake butterfly unit tends to get cracked.

Make sure that the gas pedal is not sticking too.

Sent from my POCOPHONE F1 using Tapatalk
Took a video today.
I pressed the gas pedal a few times as you can see during the video.
 

·
Registered
Joined
·
10 Posts
Hi Fredrik, take a look at this internal thread. It is describing how to diagnose trouble with a 230E in a 190.
 

·
Premium Member
1993 300CE Cabriolet (mine) ; 1994 E320 Wagon (wife's) ; 1990 Benz 300E 2.6 (son's)
Joined
·
6,971 Posts
The throttle linkage on a cis car should be lubricated with every oil change. On a 300E this is under the air cleaner.
 
1 - 6 of 6 Posts
Top