Mercedes-Benz Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
hi guys , i need help my 1995 S500 coupe misses at higher engine speeds around 4500rpms, and sometimes at lower speeds as well its like it drops a couple of cylinders then coughs and comes right like a fuel blockage ? the check engine light does not come on at all its done 80ks, it seems to do it like once a week maybe fuel filter?? any help i can get i would be very greatful thanks in advace
 

·
Registered
93 500SEL
Joined
·
40 Posts
Wow, I have this excat problem right now on my 1993 500SEL. I just had the transmission rebuilt cause it would slip real bad when it was shifting. When I got the car back it shifted perfect, except under wide open throttle. This car starts out in 2nd gear if you have the 4spd automatic. The 5spd auto has a switch that will let you put it in sport mode and will start out in 1st. When I mash the throttle it takes off and when the tachometer climbs to about 4k it starts spuddering like its go a fuel cut off or a govenor on it. It continues this until the engine finally climbs, hickuping all the way to 6k, then shifts and starts all over again at 4k. If I let up a bit on the pedal it will shift fine, but not at wide open throttle. It has got better it used to do it in every gear. Now it shifts from 1st to 2nd without hickuping. I took it back to the tranny shop who has rebuilt 12 trannys for me over the years and very professional. The tech went for a ride with me and when i showed him this problem he said it wasnt with the tranny. I dont know if I agree. The shop who works on my car just got a new Mercedes Master Tech and he is looking into this. I have had this car for almost 3 months now and have only drove it handful of times. It has been in the shop from the first day I bought it. It went from the mechanic, to the auto body shop to the tranny shop and now back to the mechanic shop. I thought I got an amazing deal on this car for 7k but I have dropped 13k in repairs since I bought it. When I drive this car and it hickups its at higher speeds. When its starts the car wont go anyfaster than 75-90mph. Under wide open throttle it wont let the tranny go into overdrive or 4th so it top end is only 120-125mph. I know you saying thats fast enough but its still not correct. When I bought this beater it was leaking oil and powersteering fluid from every where and I sit thsi need on the 160mph area so something is screwing up. The new master tech at black forest motors thinks it need an adjustment in the valve body. When the tranny shop rebuilt the tranny the did install some updated valve body springs. The tranny tech said it is coming from the engine stalling at wot. It feels like the fuel is cutting or being restricted at wot. Its driving me nuts, but black forest motors who works on all my benzes said they will get it corrected. If anyone lives close to indianapolis and wants first class service at about 60% of dealer prices the look them up. Keith is the manager 317.546.6776 This car has been more expensive than my last 2 ex wifes, but I wont give up. My SL55 and G55 have yet to make me lift the hood. I guess it god trying to teach me patience. I will keep you posted on what fixes this. i pick the car up Friday and get to drive it back to the body shop. Maybe one day I will be able to drive it home.
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
What's the condition of all parts involved in spark generation?

Spark plugs, spark plug wires, ignition coils, distributor caps and rotors. Also worry about the wiring harnesses in the engine compartment, specifically, the throttle actuator, air-mass meter, and fuel injector harnesses.

Maybe fuel delivery... Fuel pump and filter.

Brett
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
i know what you mean i have no trouble with my SL either apart from a loose starter wire , my S500 doesn't do it all the time if i drive normal it changes gear ok, it just does it when the pedal hits the metal , but getting back to your problem my freind had a 500SL that had to have the tranny fixed same sort of problem as your discribing the problem was when they put the trans back in they knocked the selector into the B postion, it would go through the selector ok but the b was stuck on took ages for them to figure it out ,just check yours it might be that simple just make sure you feel it engage in the selector if you dont you just need to flick it back again , fixed my freinds problem good luck
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
RE: What's the condition of all parts involved in spark generation?

thank god i got a 5 year warranty with the car if i drive normal she goes well only gives a litle cough if i over take someone .. will take it in to get a good service replacing fuel , air filters and a check over fingers crossed
 

·
Registered
95 S500
Joined
·
31 Posts
Well let me join the club too, I have same problem on my 95 s500 @ 4500RPM starts acting funny. I will get it checked out at dealership after i change windshield, 4 tires, rear axle...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
well good luck my coupe goes in on tuesday thought i would wait till after easter so they don't rush the job , its like its hitting a speed inhibator at 4500 revs ..i am hoping its a fuel filter blockage but knowing these it will be someing that costs an arm and a leg hee hee still they are a great car
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
I have a 94 and its equiped with the led under the hood that allows you to check for engine trouble codes, have you guys cared to check for that? I had a very similar problem and it was my EGR valve. A while later I found out that I did have an EGR malfunctioning code, I believe 5 blinks, I erased it and never came back.
 

·
Registered
1991 300SEL W140, Brabus, W220 facelift
Joined
·
196 Posts
Perhaps you already solved the problem, but anyway:

I had the same problem with my 300SEL.

Sometimes it would also miss at lower rpm's when warming up in humid conditions.

Yesterday I replaced the ignition coil, and now i runs at any rpm without problems.
 

·
Registered
Joined
·
1 Posts
I am a newbie. But what a great forum!
Diagnosing the real problem seems to be an issue for some of our main dealers in the UK. My S500 (1997) missfired and shook at high revs. It turned out to be the air mass convertor and an ignition coil. Now it runs like an absolute dream. THe air mass convertor was about £320. The ignition Coil was £50. Fitting, (in the Uk) was £900!!
Mac
 

·
Registered
08 S63 AMG 05 CL65 AMG (Renntech) 83 500SL AMG
Joined
·
27 Posts
had the same problem when I had a 94 s420. It was the distributor cap
 
1 - 11 of 11 Posts
Top